QGroundControl kills internet!

Just installed QGC daily build on a new HP Windows 10 laptop. When I start it the map is blank… okay maybe taking a while to download the tiles for the first time.
I connect my Pixhawk Cube with the intention of uploading a new PX4 firmware (coming from MP and want to try PX4 and QGC for setup and tuning). NOTHING… keep getting an error message. Go to look on the forums, no internet connection. eh?! So I check my router - all good. I check the internet on my desktop - all good. Have a look on the terminal screen on QGC and error after error - “No internet connection”.
So I shut down QGC and come here - internet is back!

Okay, so I’m totally confused. QGC is killing my internet connection on this laptop once it is running. I’ve tried the stable release and the daily build - same problem. I’ve installed QGC on my desktop - no problems there. My best guess is that the driver is blocking a port somewhere so I’m going to check that next but if anyone has any ideas in the meantime I’d be happy to hear them…


…and just like that it appears to have fixed itself!

Oh well, I’ll keep playing and try to work it out if it does it again. Still suspecting a port issue was to blame.

As long as only your internet is killed and not mine too, it’s not so bad. :smile:.

By any chance, are you using internet through 3G/4G modem using a sim card? Because in that case I could imagine that QGC tries to grab the serial port, at least there could be conflicts for Linux because both go to /dev/ttyACM0. We used to have conflicts when ModemManager on Linux tried to talk to the Pixhawk bootloader.

Could be related to this : https://www.reddit.com/r/krita/comments/9xea9b/this_is_gonna_sound_crazy_but_is_krita/

could solve it

I guess you can compile QGC yourself and try it out.

lol ! What an answer …
I’m not affected, just to report that QGC might have this problem due to Qt !

This is doing my head in! I’ve tried everything and I still can’t get internet access when running QGC. I tried that QT_BEARER_POLL_TIMEOUT fix and it didn’t help.

I can work around it for now but it would be useful to have my laptop at the field working for tuning etc…

1 Like

Bit of an update…
I was doing some searching and discovered a thread on Github from over a year ago where the same thing was happening with the then newly released V3.2. What I am doing now is rolling back to 3.1.3 to see if that fixes the issue and then I can go from there.
It does appear to be a very specific issue with only some machines but it isn’t just me (phew).

EDIT: Yep, that solved the issue. It’s something in the newer version of QGC that is causing it…

Really odd! @DonLakeFlyer any idea?

Not ringing a bell. Where’s the similar issue for 3.2?

It was this thread from a while back:

I’m not sure if I mentioned here but I did on the Github thread, I tried installing 3.1.3 on my machine and the problem went away. Tried 3.2 and it was back again.

PS, this is definitely a hardware issue I think as on my desktop (Intel Core i7) I don’t have the same problem. I also tried a Panasonic Toughbook, which is used as a GCS for another aircraft (Intel Core i5) and no problem there either. It is only this laptop (AMD Ryzen 5 2500U) which is playing up! Could it be the processor?

Hi I am having the same issue with ver 3.5.4 on my android tablet. For some reason it will not load any map tiles. I checked the logs and noticed a no internet access code. Do you know if there is an update or patch to fix this issue? Thanks for all the help provided.