Servo set up Pixhawk 4

I am trying to set up my servos but I get no response from them.

I have a pixhawk 4 plugged into the computer via USB. The Receiver is a Futaba 2008SB which should be an SBUS capable Rx.

The PMB is plugged into power 1 and I have a servo plugged into the FMU output ch1 on the PMB.

The FMU and I/O out on the pixhawk are plugged into the PMB in their respective in slots.

I also have an external BEC powering the servo on that FMU output bus.

I have a PPM Encoder and it’s plugged into the PPM slot on the pixhawk, and connected to my RX. The RX seems to be receiving power just fine. When I open Qgroundcontrol it recognizes the inputs from my Transmitter (futaba 14SG), but I’m getting no response from the servo.

I’ve tried different combos of plugging this or that, I tried using the sbus channel on the RX and Pixhawk (doesn’t even recognize the radio at that point). No matter what I try, I can’t get this thing to move the servos at all. Can anyone help me get this set up properly?

Hi, I used this radio setting:


Additional Radio Setup

Aux2 PasstroughRC Channel --> choice to listbox your relative channel radio

by

Actually I found my issue, I believe.

I needed to plug IO out to FMU In, then I had to set up Pre-arming. I didn’t know that in an unarmed state it would lock the servos in place.

Now with pre-arming in place, I can wiggle the roll, yaw, and pitch servos, which was what I was wanting to accomplish for now!

Now I have to build the aircraft.