Config of Pixracer R14 in QGC fails

#1

I ended up with three errors during/after config:

  1. Compass config failed due to out of memory. Disabling of Sys_Companion solved this.

  2. Level Horizon config fails with error message “attitude estimator not running - check system boo”. I have thoroughly searched for info on this but not found a workable solution.

  3. Preflight check fails with message “no baro sensor 0”. Seems clear it is a faulty sensor but later I have found info which points at this has been solved using other firmware (I am using stable 1.7.3). I have tested other firmware version without positive result but behaviour is such that a firmware problem is remotedly possible. I am new to QGC and PX4 so I have no idea how the the baro 0 can be health checked and logs have not been helpful.

With these two problems the Pixracer is unusable so any help will be highly appreciated.

#2

After a lot of searching I stumbled on a couple of postings which referred to the “Level Horizon” problem.

It turned out that the attitude estimator could be manually started from the MavLink console by using the command “attitude_estimator_q start” and this solved the problem. Without knowing the details I assume that this process should be running from startup because a manual start seems to be just a work-around and not a normal and documented procedure.

The third problem “no baro sensor 0” is still not solved. A check of the devices does not show any /dev/baro0 or similar device but I am not aware of how this should be set up so it is just a guess and I am not skilled enough to dig into the code find out. As mentioned I have found a couple of cases (but not for a Pixracer) where a change of firmware has solved this problem but my tests of that has not helped so far.

Does anybody have a clue what might be done solve this or firmly establish that the baro sensor is broken?

#3

A bit later add on.

I had the following issue when adding a gps and mag to the pixracer.

Start the individual calibration steps by clicking one of the buttons to the left.
[cal] calibration started: 2 mag
[cal] Skipped scale calibration, sensor 2
ERROR: out of memory
ERROR: out of memory
[cal] calibration failed: mag

It took me a while to figure it out, but because I don’t have a wifi module I added a sik radio. Now, when calibrating it through the radio i got the memory issue. This was fixed when calibrating through usb.

I am adding this because I have found no documentation on this so far.