RFD 900+ Sik Radio cannot update firmware?

Hi, I cannot update the firmware of the RFD900+ Sik radio due to the upgrade cancelling because of the error:
Error: Unable to put radio into command mode
Update cancelled
Any ideas what’s going on?
Radio is turned on and connected to computer via FTDI USB.
Tried updating drivers and rebooting system, still didnt work

I had the same problem, you can’t update these radio firmware using Qgroundcontrol.
What you need to do is to use RFD’s firmware tool then click directly on update firmware.

1 Like

Hi, I tried updating the firmware, but the modem cannot “enter command mode”, even after power cycling.
The modem has been unable to enter command mode for awhile now, what does it mean?

First check you have the rx and to wires correct. If you can connect and read settings they are. If not, reverse them.

Second is to force bootloader mode. Look in the RFD manual for which pins you short during powerup and you should be good to go.

1 Like

I have switched the rx and tx wires, and the firmware is able to be uploaded.
However, the rfd 900+ led remains red after firmware upload, and am unable to load settings or reset to defaults due to:
“Unable to be put into commmand mode”
How do I change the red led back to green so that i can connect QGC to px4 via RFD?

If you’re stuck in bootloader mode first thing is to reflash another firmware. Try going a version back if the version you’re uploading doesn’t work.

Can you read any settings? If so I’d enter the command line/terminal built in to the rfd tools and type atz and hit return which is reboot. All the AT command are in the manual and you can reset everything to zero, etc but first try uploading the firmware again.

Hi I was unable to read settings, however, I rewired the pin connections and have now successfully connected the two radios with packets being sent on both sides.
Thank you all for your wonderful advice!