Reverse transition from a fixed wing to a copter

Hi, I recorded 1.10 and I can’t switch back to the copter. Only the transition to a fixed wing works. It remains a firm wing until it turns.
I didn’t find anything in the settings. I followed the instructions.
http://docs.px4.io/v1.9.0/en/config_vtol/vtol_back_transition_tuning.html
What am I doing wrong. How to set up
Can anyone advise me, please?

I don’t really understand what you mean.

Could you describe exactly what setup you have and what you are trying to do, and maybe also share a log?

Ahoj, omlouvám se používám google překladač.
já mám Vtol.
start multikoptéry - OK
přechod z režimu multikoptéra na pevné křídlo - OK.
pevné křídlo letí - OK
přechod z režimu s pevným křídlem na multikoptéru - KO - přechod neprovede (stále pevné křídlo).

Protokol:
https://logs.px4.io/plot_app?log=8d0cc545-9953-4368-b98b-e12e46b94807

Hi, sorry I use google translator.
I have a Vtol.
start multicopter - OK
transition from multicopter mode to fixed wing - OK.
fixed wing flies - OK
transition from fixed wing mode to multicopter - KO - does not perform the transition (still fixed wing).

That looks strange. I’m going to ping @Roman on this, hoping that he can have a look at the log.

Hi, I have similar problem and I’m wondering if you have found any solution @Roman .

Can you provide more details of your build, i.e.

  • What flight controller?
  • Firmware version?
  • Airframe?
  • Maybe you could provide your params file.
  • Can you confirm that when you do this on the bench, the MC motors won’t start and FW motor keeps running?

Hi @rollys

  • I’m using pixhawk 2 cube
  • Firmware 1.10.1
  • Airframe: Generic AAVVT v-tail plane airframe with Quad VTOL
  • most of the settings are default
  • I do not preform real flight and I just simulate start with out propellers. When take off the multirotor works fine (also in real flight) transition to FW works fine to but when I’m trying transition back nothing happen. I have tried do it by RC and QGC as well but same problem. I can’t disarm as well and I have to use killswitch.
    Here is some log plots
  • I don’t think it’ll make a difference but change VT_B_REV_DEL = 0 ; VT_B_TRANS_DUR = 4; VT_B_TRANS_RAMP = 3
  • What Flight Mode are you in when you transition, i.e. Stabilize, Loiter, etc.?
  • I have no personal experience with the Cube and whether it’s related to it or not, but I’ve run across some posts of folks who have had issues with them.
  • For diagnosis purposes, switch the airframe to the Baby Shark VTOL SYS_AUTOSTART = 13014 and its respective connections and see if that works fine. If it does, then file an issue in Github.
  • Maybe try switching firmware to the beta version or maybe even a previous one and see if that resolves it. If it does, then I recommend filing an issue in Github.

Good luck.

Unfortunately, after many attempts, I did not manage to switch to FW mode. I try Baby Shark airframe and I set all parameters you sugested but still no resoult. I will not give up on tryes and if something work out I will post here.

Hello, I have the same issue. It’s when the VTOL is in fw mode in manual and with the parameter VT_FW_PERM_STAB = 0.
This bug is in firmware 1.10.1 and is solved in v1.11.
If you can’t update to v1.11 you can use VT_FW_PERM_STAB = 1 or before you do a back transition switched to another flight mode (altitude, position…) or delect the condition " if (mc_att_sp_updated || fw_att_sp_updated) {" here :

1 Like