Retry Calibration (Unable to fit mag 0)

Hi, I am currently using QGroundControl and I am trying to set up my calibration for my Pixhawk. But this error keeps showing up when I am trying to calibrate my Compass Sensor. The error is as follows, Retry Calibration (Unable to fit mag 0)

I’m getting the same error with a Pixhawk 6C
make px4_fmu-v6c_default. (Built on 9/22/2022)
Try going to Analyst Tools, and click Mavlink Console. Note the Pixhawk 6C uses: the ist8310 magnetometer. I’m seeing bad register events and bad transfer events. Try the commands below at the nsh> prompt.

nsh> sensors status

nsh> ist8310 status
INFO [SPI_I2C] Running on I2C Bus 4, Address 0x0C
ist8310: reset: 1922 events
ist8310: bad register: 1913 events
ist8310: bad transfer: 2240 events
nsh: qmc5883l status: command not found
nsh> qmc5883l status
INFO [SPI_I2C] Running on I2C Bus 2, Address 0x0D
qmc5883l: reset: 1 events
qmc5883l: bad register: 0 events
qmc5883l: bad transfer: 0 events
nsh> hmc5883 status
INFO [SPI_I2C] Running on I2C Bus 1, Address 0x1E
hmc5883: read: 92088 events, 83581572us elapsed, 907.63us avg, min 849us max 1880us 149.836us rms
hmc5883: com_err: 0 events
interval: 6666 us
@dagar @bkueng

For me this was caused by MATEKSYS Digital AirSpeed Sensor (ASPD-DLVR, CAN, I2C & UAVCAN) plugged into the 12c port without removing the two resistors to pit it into 12c mode. Looks like PX4 does not support this airspeed sensor mode in DroneCAN mode. I want to keep the sensor in CAN mode so I replaced it with FPVDrone PX4 Differential Airspeed Pitot Tube + Pitot Tube Airspeedometer Airspeed Sensor for Pixhawk PX4 Flight Controller. Sort of sucks, but it works now.