Red LED with every other LED

Greetings everyone!

I have a Pixhawk 2.4.8 board mounted on a quadrotor. It was working well and good until May, when a bad motor caused the wire connecting an ESC to the Pixhawk to melt (I don’t know the exact reason, but the black wire just melted). I recently repaired all the connections and tried booting up my board again. All the sensors are working fine, the boot up routine is fine, I was even able to update the firmware to Ardupilot 3.6.9, but I am not able to arm my quadrotor. I can pass all pre-arm checks, but there is always a faint red LED along with any other message (blue + faint red, green + faint red). This red LED thing happens only if I connect the battery to the pixhawk using a BEC, and not if I power it using a USB cable. Does this mean that my Pixhawk is fried, and is there anything I can do to repair this damage? I tried searching online but got no solution. Any help will be appreciated :slight_smile:

Here is a video of the blinking light: