Unable to Arm Pixhawk or spin motors

Hey guys,

I am a beginner building my first quadcopter using a Pixhawk 2.4.8 Flight Controller and I have flashed it with PX4 1.10.1 using QGC.
RC Transmitter: FlySky FS-i6 2.4G 6CH PPM
RC Receiver: FS-iA6B
Battery: 3000mAh 3S 30C/60C LiPo
Motors: A2212 1000KV Brushless Motor
ESC: Simonk 30A

After flashing PX4 I was able to successfully complete the Vehicle Setup after which the main Pixhawk led flashes blue (when connected to USB) which according to the documentation means I’m Ready, Disarmed with no GPS lock.
So I remove the USB and plug in my LiPo, the main LED shows a solid red as the Pixhawk initialises successfully (at this point the red is followed by the LED flashing green). But the welcome tune is followed by a sad tone (which sounds like a single burst of the “Program PX4IO Fail” sound in the documentation but doesn’t repeat) and the main LED flashes blue and purple/red. I am unable to arm the quadcopter and the motors won’t spin.

I have uploaded the pictures of the lights I see when I plug in the battery and renamed the images 1 2 3 4 in the order that they appear. The last red in 4 looks more like purple to me in real life, but I’ve written it as purple/red.

To check if the motors and ESCs are healthy I have also tried manually calibrating every motor and ESC combination. However, even that has failed. So I have been unable to see a single ESC or motor in action.
I am using this procedure:

I can’t attach any log files because I can’t find any on QGC. I have tried to refresh the system but I never get any log files. Is that normal?

A huge part of me doesn’t want to believe that Amazon will equip me with 5 sets of faulty ESCs and Motors, so I’m posting my situation here and hoping for some help.

Thank you for your time.


Something is wrong with this. Can you try to connect power while pressing down the arming button? This would force a PX4IO update.