Double-red-LED flashing with PX4

Hi y’all, I have a problem with my Hexacopter using the pixhawk PX4:

When I power the copter, pixhawk makes the normal starting sounds, but the LED starts to flash in red (double flash, pause, double flash, …) instead of normally first blue, and then green. I am still able to connect to mission planner on my laptop (both remotely and via USB cable), but when I try to connect to my remote control (FrSky Taranis X9E), it does not show the battery level of the copter and also won’t arm the copter (even though it seems to be somehow connected, because when I remove the battery from the copter, the remote control says “telemetry lost”).

Does anybody have an idea about what could be wrong/how to fix this? What I have tried so far is changing the receiver telemetry of the copter, and installing the most current firmware using the mission planner software (did not change anything though).

Thank you in advance for your help!

I have managed to solve the issue. I replaced the transmitter on the UAV that connects to the remote control. Now it works fine :slight_smile: