Rc-input not affecting actuators

Hi i’m having trouble with the rc of a rover:
Airframe: Aion Robotics R1 UGV
What does work:

  • Rc input (as seen in QGC under “Vehicle Setup”>Radio and when running “listener manual_control_input”)
  • Actuator controll as seen when using the sliders in “Vehicle Setup”>Actuators
  • Arming the rover with the rc

My Problem:
Trying to controll the actuators using the rc (the Rover is armed and “flying”).

I have tried multiple PX4 versions (inluding main and 1.14 release)

I’m quite lost here and don’t really know which information might be usefull, so let me know if you need more info.

Can you try to drive the rover and listen to the topic actuator_motors and tell me what you see? The output module pipeline seems to work as you can control the motors using the sliders, so I believe the issue should be on the PX4 side.

Please check the file below.

PX4-Autopilot/boards/px4/your board/default.px4board


Hello, has anyone been able to solve it? I can´t use a rover with 1.14 :frowning:

Hey, yeah although i have no idea what did the trick.
I swaped between diferent px4 versions and did a paramter reset on an older version after which it worked. I then switch to the version i originally had the problem with and it still worked. Im pretty sure i did a reset before on the original version with no effect though.

I guess start with a parameter reset and if that doesn´t work, work your way backwards through different version (while reseting parameters) until one works. At which point you should be able to go back to the original version.

Thanks for your message.

Finally, I solved it with the help of @eogks8921

To solve this problem: you need to write CONFIG_MODULES_ROVER_POS_CONTROL=y in default.px4board (of your specific board) and build again. If you face some kind of memory error, delete no use modules.