Quadcopter crash with stable stack

Hey guys,

i had a crash with my quad last week. before crash day i flew in manuel mode, mission mode and some simple setpoint_position in offboard mode without problems several times. but this time i tried to arm, takeoff und fly to a fixed setpoint in offboard via mavros. it armed, took off und flew in to some trees directly without switching into offboard mode.

here is the log file. look at the localposition x/y :confused: has the flightcontroller crashed?
http://logs.uaventure.com/view/M8fPtzaCViiGPUBzQLV4Mk

i am using QGC and PX4 stack as stable versions. This wasnt the only crash with stable stack.

this monday i flew a mission and started it with QGC. RC Mission Switch was zero. i wanted to abort the mission and switched the mission switch from zero to one and back und wanted to land the quad with my remote, but it began to escalate and i could get it under control.

I’m pretty sure this is a hardware related issue. Your pitch tracking looks horrible right from the start. Your vehicle is not fit to fly and something is fundamentally wrong with the control along the pitch axis. It does not respond at all to the autopilot inputs.

thanks for your quick answer. i will try another px4. maybe it is damaged

i have tried another px4 fligthcontroller. same behaviour. i think it is something with my code. but it is working flawlessly in my sitl simulation.

my statemachine:

  1. setting home (dont know if it is setting right)
  2. arming (working)
  3. auto-takeoff (fly away)
  4. offboard (would be nice if it reachs this point)

is the local_position frame == home-frame? when i am setting a new home in my sitl simulation the published local_position/pose doesnt change, but when i am using RTL it lands on its new home :frowning:

sethome = rospy.ServiceProxy(’/mavros/cmd/set_home’, CommandHome)
sethome(True,0,0,0)

with this parameters i thought it uses its actual gps position and ignores longitude and latitude.


takeoff = rospy.ServiceProxy(’/mavros/cmd/takeoff’, CommandTOL)
takeoff(10, 0, 0, 0, 10)

with this parameters i tought it starts on its acutal position which is set as home.


my question, is the takeoff command using home frame for auto takeoff when parameters are zero and is my home set to longitude, latitude == 0 in addition?

i dont know :frowning: should i try the beta stack because of working simulation and not working realife?

Update:

Next crash.

this time i used

takeoff(0, 0, latitude, longitude, (altitude + zOffset))

same behaviour. somebody out there who is using auto takeoff command via mavros and can confirm that there is something broken?!

sitl is running everything fine.