QGC initialize UAVCAN for px4 flight stack (Solved)

#1

Hello! I use last daily build QGC. I updated of firmware by QGC and selected PX4 Flight Stack 1.8.0 (Stable).
I want to start using uavcan and I have no expirience.
And I can not to search parameters for UAVCAN enable and settings.
Moreover I could not find parameters for CAN at all.

I try to use stable QGC version and dev build version for firmware, but it did not help.

In accrording Zubax manual for UAVCAN initializing I hope to see “Enable uavcan…” checkpoint on Power tab, but it is not.

1 Like
#2

The problem is solved!

The QGC recognize my hardware as PX4FMU_V2, and offers to use firmware limited size < 1MB and uavcan was not included in this firmware.
My hardware have 2 MB flash and I downloaded px4fmu-v3 release (https://github.com/PX4/Firmware/releases) and upgraded px firmware by this version.
After this operation UAVCAN_ENABLE parameter appeared in QGC.

1 Like
#3

Hi,
Yes, I was also able to fix the issue. But as per the documentation, the uavcan subscribe function for esc is not working for me when I initiate the command “uavcan start”.
Do I have to enable any other header apart from what you mentioned above?
any pointers would be helpful.
Thanks and regards
Niranjan