Problem with configure UAVCAN for PX4 Fligth Stack (Solved)

#1

Hello! I have a pixhawk hardware and I want to use UAVCAN protocol for ESC. I tried to configure PX4 Flight Stack 1.8.0 by means of parameters in QGC according with Zubax manual https://kb.zubax.com/display/MAINKB/Using+Sapog-based+ESC+with+PX4
I used last daily build QGC, updated of firmware to PX4 Flight Stack 1.8.0 (Stable).
And I can not to find parameters for UAVCAN enable and settings.
Moreover I could not find parameters for CAN at all.

I do not know why uavcan parametes is unavailable. May be anybody did encountering with like problems and can help me?

2 Likes
#2

The problem is solved!
The QGC recognize my hardware as PX4FMU_V2, and offers to use firmware limited size < 1MB and uavcan was not included in this firmware.
My hardware have 2 MB flash and I downloaded px4fmu-v3 release and upgraded px firmware by this version.
After this operation UAVCAN_ENABLE parameter appeared in QGC.

4 Likes
#3

Hi Seregakai,
Are you still working on uavcan? Saw your posts regarding uavcan.
Thanks and Regards
Niranjan

#4

Hi! Now I have stop working with uavcan.

#5

Thank you for the reply.