Qgc, h520g, ipad pro

We have a H520G and unable to get QGC to connect to the platform. It keeps saying waiting for connection. We have the ST10C connected to the ipad via usb-lightning cable. Anyone else having this issue??

Hey Chris, you weren’t able to get tech support from 3DR? Those are the guys that we bought from and help us. Either way, this happens a lot of times and quitting the app helps after every flight.

Here’s what worked for me:

  1. Update to latest QGC
  2. Go to QGC > Settings > Comm Links > Add a communication link:
  • Type: UDP
  • Port 14540
  1. Want to extend range?
  • On a laptop attach and install an external long-range WiFi module
  • I used Alfa AWUS036ACH, I’m currently getting 0.5 miles
  1. Add Live video streaming:
  • Settings > General > Video >
  • Video Source: RTSP Video Stream
  • RTSP URL: (rtsp://
  1. Go to Settings > MAVLink
  • Change Mavlink Session ID to anything below 255, I used 200. This will fix the conflict between only having remote or QGC telemetry working simultaneously.