How to stop using a high latency connection for QGC?

Hello, very new to QGroundControl, but I’m looking to learn more. I was setting up a QuadPlane VTOL and I couldn’t get the parameters to download from the drone to the controller. I keep getting the error MAV_CMD_CONTROL_HIGH_LATENCY command not supported. I can control the drone manually on the ground, it responds to mode changes and the control surfaces move correctly, but I cannot upload flight plans or download the complete parameter list.

I am using a fully integrated remote, the H16 loaded with the most current version of QGC. I’ve reinstalled it a few times with the same results. I installed Mission Planner, and although it was pretty clunky on the H16, I was able to upload mission plans and download the complete parameter list without any errors.

The flight controller is the Orange Cube.

My theory is that the manufacturers did the test flight with Mission planner flying from a laptop, then bound the H16 to the drone afterward and called it a day. How would I go about changing the settings (and what settings should I change) to make it send and receive data over the radio, not a high latency connection like satellite?

Thanks in advance for the help!




Pretty basic answer, but I figured it out for anyone that might run into this dumb hangup when setting up their system for the first time. Did a clean install of QGC. It will ask to set up connections for the first time. The settings for connecting to the drone on an H16 are UDP listening to the port that is adding “1” to whatever is the automatic option. for example, mine recommended 15540. I set it to 15541 and it worked great. There is a checkbox for the high latency option that must have accidentally been checked on my H16 remote during the last setup, but since it couldn’t communicate to the drone, I couldn’t even get to that setting to begin with. Works perfectly now.