PX4 with Minimosd

I’ve been struggling to configure a minimosd with the pixhawk running the px4 flight stack. I can get overlays on the screen, but much of the data is missing or incorrect. I have the minimosd plugged into the telemetry 2 port on the pixhawk and am recieving the correct data through my tbs crossfire on taranis, so I think the telemetry data coming out is correct, however, the data on the osd is wrong. I can’t get the flight mode to change, the battery voltage is wrong, the current sensor is incorrect, and the rssi is perpetually 39 (%? dB? i don’t know). I’ve been struggling to get this to work for several weeks now and I just can’t seem to figure it out. Any help would be greatly appreciated. I am running the latest px4 stack from qgroundcontrol and night ghost’s minimosd extra release 934 on mavlink.

Thanks very much!

There is a new Version for PX4 of MinimOSD Extra as Flightmodes are transmitted differently between AC and PX4. As for Voltage and Current, I have correct Values also with earlier versions.

Thank you for your quick reply,

I am familiar with the newer versions of the minimosd firmware, however, after v934, the osd does not display anything. I looked through the minimosd forum and other users have also documented this weird problem. Is there something that I am missing there? The newer firmwares are supposed to have px4 stack implementation, but I just can’t get anything after v934 to work. As for the earlier versions that your voltage and current work on, which version are you using? Does all the information come through?

Thank you!

Also, it seems that I cannot calibrate the esc. It stays in the max position but never comes back down to the min position. As a result, the esc goes into programming mode. I have confirmed the same behavior plugging a regular servo into the throttle port (main 3) and see that it jumps to max, but never goes back to min. What’s going on here?

Any ideas? really stuck here

Hi, sorry for the late reply. I think I’m using somewhat around 928 or so…

Yes I get correct Voltage an Current measurements. Do you get those in QGroundControl?

ESC Calibration did never work for me. The DJI’s I use don’t support it and the HobbyWing x-Rotor 40 I did manually by directly connecting them to the RC Receiver. No harm in doing so, you can adjust the PWM Setting of PX4 to your needs later on.


Thank you for your help, I tried flashing the osd with 928 and I get a bouncing voltage. The voltage readout is correct on my taranis telemetry, but the osd show the voltage moving all over. Also, I tried to calibrate the esc using external receiver. It works, but then when I plug esc back into pixhawk, I get a rapid beeping noise, and then a slow beeping noise, which I think means that the esc is not getting a 0 value.

Any ideas?

I’ve gotten my plane together and am now working through just the osd and esc problems. Osd still has voltage scrolling from low to high voltage over and over, no flight modes or rssi, and esc doesn’t want to calibrate to the pixhawk. This is very frustrating for me as these are the only things holding me back right now. I’m not sure if it’s the fault of the hardware, pixhawk PX4 flight stack, minimosd, or something completely different, but, I just can’t for the life of me figure it out.

Any help would be appreciated!