ESC calibration with Qgroundcontrol: "calibration failed timeout waiting for bat"


I am working with a pixracer and a Qbrain 4x25A ESC. I tried doing the ESC calibration through QGroundControl but got the message “calibration failed timeout waiting for bat”. I measured the voltage across the battery pack and it seems ok.

I haven’t configured the RC because I don’t have the receiver yet. Should I configure first the RC? Or should I be able to do the ESC calibration right now?

Thanks in advance and apologies for opening two threads in such a short timeframe.

are you powering the pixracer with a power module which has voltage and current sensors?

I’m using an ACSP5 power supply and this battery

But it is working now. I added more memory and processing power to the virtual machine and it seems to work better overall.

Now the issue I have is that when using Qgroundcontrol to bind the RC receiver I get a ‘bind command not supported message’.

You need to update the software on the autopilot. Try the latest beta of PX4.

I tried the beta last Thursday. Should there be a change since then?

I have the same problem: the ESC’s calibrate fine when I connect them to a CC3D flight controller, but the Pixracer + ACSP4 power board result in the “calibration timeout waiting for bat” error. Using QGroundcontrol 3.0, flashed the pixracer with standard, beta and master firmwares, same result.

Anyway, could anyone explain to me what this error means? Is my power distribution board shot? Or the pixracer?

Do you mean qgroundcontrol by virtual machine?If yes how you added more memory and processing power to it?

When i am calibrating ESC in Qgroundcontrol, I am getting error in Octo cox airframe "calibration failed timeout waiting for bat”,
My Qgroundcontrol version is v3.2 and Firmware is 1.7.

Help me
Thank you.

Hey guys. This has happened with my grouup as well with our Pixhawk, and it was a silly thing but if you are just powering the Pixhawk through USB instead of through the power port on it with the Power Module that comes with the Pixhawk, it will give you this issue. So the “waiting for bat” is referring to power coming into the power port of the Pixhawk. I suppose then if you are doing this and still facing issues, then perhaps you start at testing out the port and such before moving on to trying other firmware or different ESCs or debugging your PDB (like we did).

Hi, here’s my order of doing things (doesn’t work and causes problems):

  1. Click “calibrate” button in power tab.
  2. Connect power module to battery.
  3. Connect pixhawk (2.4.8) to power module.
    Still throws the error.
    I’ve tried manually calibrating the ESCs but then there are delays between each motors spinning when armed.