PX4/Qgroundcontrol multirotor stops at every waypoint

Hi there, I am flying a quadrotor on a px4 through qgroundcontrol. I am trying to get the aircraft to fly smoothly through waypoints without stopping and I am not having any luck solving this. I am not sure how to configure the px4 because other flight modes like fixed wing clearly have to fly through waypoints rather than stopping at every one. Any advice would be highly appreciated.

Well, unlike a plane, a multirotor can stop, so I guess this is the normal behavior.

But anyway, I’m not an expert, but you could try this:

  1. Increase the way point radius. That way the multirotor doesn’t have to hit the way point very precise and it may smooth the flight.

  2. Put a few way points in a row to create a smooth circle. So for example you put a way point, 10 meters on another but with an angle from the first of let’s say 10 degrees, and so on, until you fly in the desired direction to your next curve.

And maybe there is a parameter that you can set to not make him stop, but I’m not aware of it.

Those are my 2 cents. I guess you have to experiment a bit.