PX4 Flow Sensor Setup Not Working - Parameters and Video Feed Not as Expected

Hello All,

I would really appreciate some help in troubleshooting/setting up my PX4 Flow Sensor Kit.

I am following the instructions located at the following link: https://docs.px4.io/master/en/sensor/px4flow.html

My Setup
I am using the latest QGroundControl (Linux) and a custom drone with Pixhawk 4 and PX4 Flow Sensor Hardware, both running the latest firmware. (Yes, I have uninstalled the modem manager to let QGC work as intended on linux.)

Current Status
I have updated the firmware on the PX4Flow Sensor successfully but have trouble completing any of the following steps, namely - 1) Changing the parameters and 2) focusing the lens.

Issues in Detail

  1. I am able to connect to the PX4 flow sensor and see the parameters list. Nevertheless, it seems the most important parameters are missing from the list. Namely, SENS_EN_PX4FLOW (to enable the sensor) and SENS_FLOW_ROT (To set the rotation of the sensor relative to the drone.) Please look at screenshot below for more info.

2)To focus the lens, you need to be able to see the video feed of the camera. It seems there is a tab titled “PX4FLOW” in QGroundControl that should display the camera feed, but in my case nothing is displayed. Please look at the screenshot below.

1+2) I have followed the same steps on Linux and Mac with the same outcomes for both platforms.

I would really appreciate any help. Thank you in advance.

If this is using the latest Stable 4.0 release then can you move this information to a GitHub Issue so it doesn’t get lost and then I’ll take a look. If not move to the latest stable and try it again.

Hello Don,

Thank you for the prompt reply. I do not know exactly what release it is but it does seem to be the latest Stable version. When installing the PX4 Flow Sensor firmware on QGroundControl, there are only two decisions to make.

  1. PX4 Pro or Ardupilot (I Selected PX4 Pro)
  2. Standard Version (Stable) or Custom Firmware File (I Selected Standard Version)

Where exactly should I post this as a Github issue? Additionally, if this is a problem with the latest firmware, how can I access/download an older firmware as a temporary solution?

Thank you very much for the help.

Nevermind. The fix for this will be available in a new Stable and Daily builds by tomorrow.

Hello,

Unfortunately, I just tried updating the PX4 Flow drivers via QGroundControl and I am still having the exact same issues, no change/improvements. (I tried on Mac and Linux as before.) Would you kindly provide a link to the updated driver? or a link to a previous driver that was functional?

I would really appreciate any help you could offer to get this sensor functional. I cannot continue my product development without this sensor, or something similar.

I look forward to hearing from you.Thank you very much for all of your help.

The problem has nothing to do with drivers. It is a bug in QGC. You need the latest version of QGC.

Hello Don,

Thank you for the quick reply and incredible support. After updating QGC I can now see the footage of the PX4 Flow Sensor. Issue 2 has been solved but it seems Issue 1 is still a problem. I worry that the sensor will still not work in my application. It seems that the parameter SENS_FLOW_ROT is still unavailable to edit in QGroundControl. As shown in the screenshot below, it seems that parameter is important for setup.

In our design, the x-axis of the sensor is facing towards the front of the drone, not the default y-axis, so it would seem that I need to change a parameter at some point in setup. Did this parameter change name? or perhaps it is not important anymore?

I would appreciate any help. Thank you very much for the great support so far.

SENS_FLOW_ROT is a PX4 Pro firmware parameter. It is not a parameter which is on the PX4 Flow itself.