Problem PX$FLOW + LIDAR LITE V3 sensor parameters

Hi everyone!

I would really appreciate some help about some parameters missing in my pixhawk/px4flow configuration.

Setup
I am using a Pixhawk connected to a Raspberry Pi, a PX4FLOW and a Lidar-Lite. Where I am running QGroundControl is in Windows.

I am following the instructions located at the following links:

The pixhawk that I am running it is in the version 1.10.1 for an airframe type of Hexarotor x.

image

PX4FLOW it is in the last firmware version that QGroundControl allows me to install.

Issues

  1. I achieved to configure the camera focus and also I am available to read some parameters coming from the PX4FLOW but the distance parameter is constantly 0. The PX4FLOW has a MaxBotix sonar attached to it (that I don’t want to use because I prefer to use a lidar) but it neither works. I have tried to configure the parameter EKF2_HGT_MODE to range sensor or using the barometer but I am not getting any different result. Furthermore I am trying to control the drone using MAVROS and I tried to echo the topic OPTICAL_FLOW_RAD but nothing is being published, neither the rest of topics from PX4FLOW. Other topics work correctly, just the ones coming from optical flow are the ones not working.

image

  1. I found some parameters in the list of Sensors allowing to enable the PX4FLOW, but there isn’t any parameter regarding the lidar lite. It doesn’t appear any topic regarding the sensor when I attach it. Furthermore, I tried to use the I2C configuration instead of the PWM one, but I am not able to make it appear in QGroundControl.

RESUME

  1. PX4FLOW distance not working and PX4FLOW doesn’t publish any topic in MAVROS.
  2. Lidar-lite parameters are missing in the full list of parameters.

I would really appreciate any help. Thank you in advice.