PX4 ESC Calibration - Timeout waiting for Bat

Hi everyone. I am flying octocopter coax wit PX4 and after having some issues with motors, I tried to calibrate ESC.

I read in another topics about this but I have updated software several days ago, so I doubt it is the issue.

Motors are powered by 2 14S batteries which are not routed through PDB. PX4 is powered by 3S battery through PDB.

I try to calibrate like this: Main batteries for motors already connected to ESC. When I press calibrate ESC it says to connect battery (I assume it is the one for PX4 even though it is already connected via USB). I connect battery, the motors start spinning (although in the instructions it is stated this should not happen) and after several seconds motors stop and “Timeout waiting for Bat” appears on screen.

The esc is Flame 200A by Tmotor and I have already flow with this one on this exact config. (It just started having some issues so decided to calibrate)

The battery you see being connected on the video is PX4 battery which supplies FC through PDB. Main batteries for ESC are already connected.

Any tips?
Thank you in advance!

It’s because the PX4 needs the POWER 1 or 2 connector hooked up tp detect the battery.
Otherwise it does not know if the battery is connected or not.
In your case you will need to make special arrangements for that to happen.

Hi,

in the video I have PDB connected with Pixhawk via POWER 2. It is supplied via LiPo 3S.

Still it says Timeout waiting for Bat

Do you have the CAP & ADC input connected?
Also in QGC how many cells did you tell it you have connected?

Hi,

I do not have CAP and ADC. In the QGC I put 3 cells since only 3S battery is connected to the FC.

I think I know what’s going on. The ESC goes into calibration mode on power up.
SInce you are not cycling power on the ESC they are not in calibration mode, which is why the motors are running.
However not all ESC’s even support calibration mode and you should check into yours to see if they do and what the requirements are for yours.

@jimdgit

I am using Tmotor FLAME 200A. It has calibration. I managed to do it regularly just with an RC controller and receiver (no FC in the loop). Worked fine. But I am not able to do it on the Pixhawk and PX4. All the time saying Timeout waiting for Bat.

Well the FC is not doing anything special other than what you do with the RC radio.
It doing the same thing.
If you can do it manually just do it so the min and max are the same as you have set the FC for.

Ok thanks. I thought there might be a difference if it is through the FC. Sorry, I’m new to this. We can say topic is closed. Thanks for help!