Position setpoint disjoint during survey missions

#1

Hello,

We have noticed an issue where, in survey/corridor missions mostly, the drone position set point suddenly jumps when the drone hits a waypoint. This causes the drone to pitch very wildly at waypoints.

Here is a flight log where this happens, note the spikes in local position X and Y at times 27:20, 27:24, and 27:36. This behavior has been observed on multiple drone frames and at different speeds.
https://review.px4.io/plot_app?log=4ab05bd0-5e66-47c7-bd33-a4618de3f4f2

The behavior appears to be proportional to the speed at which the drone is flying as shown in this flight log. In this log the same survey mission is flown at 10m/s then at 5m/s. You can see the same position set point disjoint in the first pass at 10m/s and you can see that the disjoint is much smaller (but still exists) for the 5m/s pass.
2nd mission

We have tried to increase the waypoint acceptance radius but that did not help. We also tried mimicking the survey mission using normal, manually placed, waypoints. This cause the issue to happen at different areas (times 1:14 and 1:25)
Manual Waypoints

Any help on this would be greatly appreciated.

1 Like