Plane Retractable Landing Gear in Manual and Auto.. How?

fixed wing norrmal plane
cuav v5,v5+
px4 1.9.2
QGC latest
“airframe reference” in docs says “main 6” is “gear channel”… so i plug in my RC Tx gear channel (7) to Main6 out, set “gear channel” param to rc channel 7, manual mode, but no response.
Actually, i get some kind of response when i activate the passthru aux1 channel - both my aux1 servo AND the ‘gear’ servo activate. huh?
i do not have any “mixers”. just default setup … seems like the docs say main6 is already mixed to gear.
i need the retracts to work in both manual and auto/mission modes. also, i found no docs discussing when the retracts would retract or extend. of course this means no param/config exists.
i saw some past discussion, but seemed to lead to silence.

Which airframe config have you selected? And do you know which mixer that uses?

(BTW. for capitalization you can use the shift key. It makes it more pleasant to read. Thanks)

heh heh. caps are too hard ;>/
Plane: standard plane … Lorenz Meier maintainer.
from the 1.9.0 docs “Airframes Reference”
notice the “MAIN6: gear” line.
…looky there- caps

I am not using any kind of “developer” setup - just user. Can i still affect mixers? If so, where can i find the documentation for instruction?
for instance, I cannot find any folder with this name on the SD card in my Flight Controller…(this is from the developer documentation…i think).

PX4 Mixer Definitions

Files in ROMFS/px4fmu_common/mixers implement mixers that are used for predefined airframes. They can be used as a basis for customisation, or for general testing purposes.

sheesh. ok…just found this… So i dont have any of these folders on my SD card either, but i will try to create and see what happens (unless someone with knowlege stops me before i destroy something accidentally)

Too bad. Helping you is too hard for me.

OK, so my ‘research’ has discovered that, although there appears to be discussions about this topic in the past, nothing is incorporated into the FW programming that operates the gear automatically on TO or landing.
(at this time) the documentation for the airframe lists a “gear” channel at channel 6, but this is merely an echo of AUX1 and will only operate as such. meaning AUX1 and MAIN6 will have duplicate PWM outputs. I have not attempted to test this in flight but, on the ground, manual operation DOES NOT WORK connecting gear to MAIN6 and setting the param “RC_MAP_GEAR_SW” to any RC channel. Getting gear to work required the RC Tx gear channel (switch) to be assigned to AUX1. i am assuming, because of this and reading previous posts about having no luck getting auto-gear to work, that there is NO AUTO GEAR CONTROL. its all manual.
really not sure why this hasnt been resolved by now. seems rather simple? if i can be of help, let me know.

i try’ed to (re)use the MAIN6 port (Gear) to control additional functionality on my UAV.
Note: my “Pixhawk 4 Mini” does not have any AUX Port.
I share the experience from 1Gump that there is no signal on MAIN6

After that i try’ed MAIN5 (Flaps) and voila it works like expected.
Assigning any RC-Channel to RC_MAP_FLAPS lead to passthrough the assotiated RC control stick.

So first of all i have very basic question:

Is there any built functionality that the FMU take control over the MAIN5/MAIN6 Port?
If so, in which flight mode or condition the FMU extend or collapse the Flaps/Landing Gear?

My Hardware:

SkyHunter 1800 (Fixed Wing normal plane)
Pixhawk 4 Mini

My Software:

Stack: PX4 Pro
Vehicle: Fixed Wing
Version: 1.10.1
Git Revision: e0f016c2b3000000

That’s all I found regarding flaps:

And I found a landing gear switch:

Hi Julian,
thanks for the information/links

But my understanding of how flaps/gears are supported by Pixhawk4 and how to configure it are not satisfied.
I studied the ArduCopter documentation about that and found easy documentaion with all the basic knowledge id need.
But it seems to me that this feature is completely renewed in Pixhawk4 so it does not help anymore.

In Manual, Stabilize, or FBW-A modes your flaps will operate manually and you can set them with your transmitter.

In FBW-B the target airspeed is set by the position of the throttle stick. If set up properly you should see flaps deploy as you lower the throttle stick through the two flap airspeed ranges.

In RTL, Guided, and Auto modes flaps settings are determined by the schedule in your parameters and the current value of cruise_speed. You can change cruise_speed to a value in one of the flap ranges from the GCS and should see the flaps deploy. Also, if you use the Do_Change_Speed command in mission flaps will be deployed when the target speed is changed into one of the flap speed ranges.
Source: Using Flaps

Any help appreciated

So you are using PX4 or ArduPilot? I can imagine that there is good(probably better) support for flaps and landing gear there than for PX4.

Maybe @rollys can help here?

@Peter_Simon Just to make sure we’re all on the same page, please confirm the following:

  • Your Rx SBUS is connected to the RC IN of the Pixhawk.
  • In Radio Calibration page, what channel is the Gear Switch and is it the same as on your Tx?
  • Is the Gear Switch Channel assigned and the same as in the Flight Modes page?
  • Before testing, do you press the Safety Switch?
  • Do you Arm the system?
  • Try changing the Airframe to Bormatec Maja or change SYS_AUTOSTART = 2105 and see if that works. If it does, remove the Y-cable, if you have one and move your servos to the appropriate MAIN ports as below:

We can go from here. Good luck.

1 Like