Pixhawk2/ pix4 pro/ qgc/ tbs crossfire

I decided to start a new discussion so I’m not butting in with unrelated items. As the topic states, I am using a pixhawk2.1 with pix4 pro loaded on it, QGroundControl and a ground station, and tbs crossfire as rc control and hopefully mavlink abilities. I also have a minmosd connected as well. I have been slowly but surely working through connecting components and trying to work through the setup in qgc. All has been going well and I believe I have things somewhat working. I should probably say that this is all going into a Ritewing Drak that I plan to use as a long range fpv wing and also for mapping.
I am trying to work through these issues I’m having one at a time. I’d really like to get it up and flying before I dive into camera triggering etc.

I currently have rc link established and when I arm the unit the servos work but the esc just beeps and doesn’t allow the motor to spin. I do know that the esc and motor work because I connected it to another receiver to test it. I’m sure I will have many more questions but I need to work through this one step at a time.

Thank you all in advance for you patients and help through this. I will admit that even though I am not new to the drone or rc world, pixhawk is completely foreign to me. I hope as this project progresses I can learn and pass along knowledge and help to the next person who needs it.

So to start off.
The px4 code isn’t designed to to use Pix4 pro software loaded onto the Pixhawk2.1.
You must use ‘px4fmu-v3_default’ - the Pixhawk2 software.

If that is not what is causing the issue, your ESCs may not be connected correctly (via the PWM) to the PWM ports.
They should be connected to outputs MAIN 1-4.
The beeps on the motors should turn off immediately after the motors are calibrated via the px4 software (on startup).

That would explain it. I flashed the latest ardupilot through mission planner and it seemed to take care of the “beeping” issue. I adjusted the parameter tree according to TBS manual, then went through the calibrations. All looked to go well until I calibrated the rc. None of the channels matched up. :thinking:

I don’t know if this is related, but some times a motor will not run IF the throttle trim control on the transmitter is not all the way at zero. In other words, even tho you have the throttle stick all the way down, if the trim control is not all the way down, the ESC never arms and the servos work but the motor does not. Try clicking the throttle trim all the way down to its minimum, then rebind and see what happens.


Thanks! After quit a bit of trial and error, I now have the channels mapped correctly but the motor still will not spin. I get a message saying that I have bad “ahrs”. I’m not sure if I mentioned, the pixhawk is flashed with arduplane 3.8.4 and the crossfire is v2.24.