Pixhawk quadcopter rollover at takeoff

Hi,
I’m trying my firsts uav take off and I’m a little bit scary :cold_face:
I’ve tested the UAV telemetry information on mission planner : Pitch Roll Yaw.
The motor blade turns on the right direction.
No warning on mision planner
Everything seems to be fine, but when I’m trying to take off with the radio (increasing slowly the throttle).
The UAV roll on the left , I’ve put a cross of thin carbon rod to prevent a second blade destruction.

Is there a tips to detect what is wrong ?
Thanks

1 Like

I’ve made a new test and same result.
At first time the UAV slide to the right , I slow down and when I increase the throttle the UAV roll over on left side.
I’ve downloaded the log :here

Thanks

Are the props on the right direction?

Is the aircraft small enough that you can hold it safely overhead while someone else arms and throttles up? This would allow you to feel what the aircraft is attempting to do.

Yes , the prop are in the right direction.
I’ve verified twice.
Tomorrow I will try to test with someone to see the uav reaction.

Thanks

1 Like

The props can also be installed upside down.

Hi,
I just installed my new Pixihawk 4 this morning as well and I’m having the exact same issue here.
The props on ours are for sure installed in the correct orientation and are spinning in the correct directions, we used the Motor Test feature under Optional Hardware in the Initial setup options and it started with motor 1 and spun every one going around the copter in a clockwise direction and they all worked properly.

Any help with this would be great!

Thanks!

Hi,
It seems the problem is in your hardware since mission planner showed no warning.
Please check the frame configuration (X, +) and re-calibrate all sensors and motors. If you have additional power consumption such as Raspberry pi, check the power is enough.
In my experience, your problem is typically caused by the calibration. Be sure that every procedure (from calibration to take off) is done on flat surface, and don’t forget to calibrate motors, too.

@Moi_Moi Just checking in to see if you did the test yet and what the results yielded.

On my end, THe frame configuration is set correctly in mission planner and we tried recalibrating everything including the ESC’s again and again, but we’re still having the same problem.

Thanks,
Cooper

I’ve found the problem for me.
The motor wiring was mirrored between left and right.
Yesterday I’ve made my first automatic fly .
Great :grinning:

1 Like

I use version 1.9.2, 4-axis “X” mode.
It must be ensured that the adjacent motors are rotating in reverse (2 of the 3 cables connected to the ESC must cross), the motor PWM must be calibrated, and the power module board (M1 / M2 / M3 / M4 / … …/M8) Welding is normal and cannot be shorted / opened.
PS: It’s important. I found that poor contact can lead to unexpected conditions in the throttle calibration step.