Pixhawk not getting connected to QgroundControl via usb

#1

Hi,
I have a holybro pixhawk-4 that I was using so far and everything worked well. It had PX4 version 1.8. So far it was ok but today it stopped getting connected to QgroundControl for no reason that I can think of. I was calibrating two cameras triggered by pixhawk’s imu and found that one camera was frequently getting disconnected. Suspecting that it is wiring issue I just plugged/unplugged the camera wires few times. I then updated Qgroundcontrol to v3.5.0 (I am using ubuntu 16.04). Suddenly I was not able to see ttyACM0 port when connecting via USB.

I am not able to connect to Qgroundcontrol (just shows waiting for vehicle to connect) therefore cant update the firmware. I tried formatting SD card, tried two different SD cards(one of them it working fine with another pixhawk), changing 3 different USB cables and tried without SD card inserted. However none works. Its the second time I ran into this (pixhawk suddenly stops working), previously I suspected that the cheap hardware was the issue.

The B/E LED of IO and FMU are solid red, PWR led is solid green and ACT on FMU is solid blue while that of IO is blinking blue. I am not able to figure out the cause of it. I would really appreciate any help regarding this.

Thanks,

#2

Try a different USB cable

#3

I have already tried 3 different USB cable, one that was working till yesterday, another that works on another pixhawk I have and a third.

#4

Did you ever find out or fix the problem? I think I have the same issue :confused: