Make px4fmu-v2_default upload and qgroundcontrol does not recognize that my pixhawk is connected


Currently I am unable to use the "make px4fmu-v2_default upload
" command to upload firmware to my pixhawk. When I attempt to use the command the code builds just fine, and nothing is a problem until it gets to the step that requests for the pixhawk to be plugged in.

As soon as I plug in the pixhawk, it boots up and all the lights start blinking and nothing. The console does not recognize that the pixhawk is connected so nothing happens.

I also attempted to connect using qgroundcontrol. I attempted to update firmware using that, but that does not recognize the pixhawk either. As soon as I connect the pixhawk and it boots up nothing happens.

I’ll attach a video of the pixhawk booting process here:

Any ideas on what could be wrong? I’ve tried different usb cables, and I get the same result.

Thank you for the help!

Try a different USB port and a known good USB cable. Also try rebooting your PC.

Thank you for the response.

I’ve already tried those steps and no results. I tried 3 different cables, and I get the same thing. I’m using a linux computer and unfortunantly I do not have another computer to test.

Any Ideas on what could be wrong?

@israelcasillas did you find the reason why it was happening?