Pixhawk Mini4 not arming without GPS magnetometer on quadcopter

#1

I seem to have found that pixhawk on Pixhawk Mini 4 requires the GPS external device magnetometer and will not arm with only the integrated magnetometer. Where do I need to look in Qgroundcontrol on Linux to see what I have done wrong.
I thought a magnetometer was a magnetometer no matter where it is located.
Please advise.

#2

I know this is a bit late but your flight controller, Pixhawk Mini 4, should have an onboard Magnetometer the, Magnetometer: IST8310. I would first try starting fresh as in, make usre your firmware is up to date, then in QGroundControl click on the ‘Parameters’ Tab to the left, in there you should see a ‘Tools’ button to the upper right. Clicking that will give you some options. I’d backup your configs, ‘Save to File’ then I’d reset all to default. This will tell you if you’ve unintentionally changed a parameter causing you issue. In that same ‘Parameters’ there is a search box in the upper left. Typing ‘mag’ there will give you some related parameters. Look for ‘CAL_MAG0_EN’ and see that you havent disabled the Mag itself. If you don’t have a wireless Telemetry link, try the following.
Remove you propellers if you have your UAS put together.
Search for the parameter ‘CBRK_USB_CHK’ and set it to ‘197848’ This will disable the USB check and allow you to arm while plugged into you computer. Reboot the flight controller and attempt to arm it. If there is a preflight check keeping you from arming you should be able to see it in the alert window. You can open it by clicking on the Megaphone icon at the top of QGroundControl. I hope you have solved this already, or that this can assist you if you havent.
Jake