Issue with Arming via QGroundControl when EKF2_MAG_TYPE is Set to None

Hello PX4 Community,

I am using a PX4 flight controller with the ekf2_mag_type parameter set to none, and I’m controlling the drone with a Futaba remote controller. In this configuration, the drone flies well.

However, when I connect to QGroundControl (QGC), I encounter an issue where I cannot arm the drone. The error message displayed is “MAV_CMD_COMPONENT_ARM_DISARM.”

Could anyone provide guidance on how to configure EKF2_MAG_TYPE=none while using QGroundControl? Any suggestions or workarounds to resolve the arming issue would be highly appreciated.

Thank you!

That cannot be debugged without more information. Messages (common) · MAVLink Developer Guide is a mavlink command sent by QGC to do the arming - it’s not an error in itself.

What you need to do is use the latest QGC daily version and click on the status area. That will show you an arming report indicating what is stopping takeoff.


That said it is most likely that you are trying to arm in a mode that requires a heading.

1 Like

I am experiencing an issue with arming my drone in different modes (Stabilized, Hold, and Manual) when the ekf2_mag_type is set to none . The preflight error message I receive is “Preflight Fail: Compass Sensor 0 missing.”

From the flight review logs, it’s evident that the ekf2_mag_type value is set to 5 and the attempted arming mode was Stabilized.

Additionally, when I checked the sensor_mag topic using the MAVLink console in QGroundControl with the command listener sensor_mag , the output was “never published.”

I have come across a discussion suggesting that without a heading source, arming might not be possible.

But the drone operates normally when controlled via a Futaba remote controller, which suggests the hardware itself is functioning correctly.

Is there a way to configure QGroundControl (QGC) to arm the drone just like when using a Futaba remote controller?

I have no idea, because to me the most surprising thing is not that QGC does not work, but that Futaba does.

@bkueng Might have some thoughts?

1 Like

Looks like something is wrong with the mag. In the log you shared there is mag data, whereas the failing preflight check and listener sensor_mag indicate there is no mag. I would start with looking into that, might be a hardware or connection problem.
Or you can also explicitly disable some mags with CAL_MAGx_PRIO.

1 Like