Pixhawk 2 mag calibration failure with here GPS module

If I plug in the Here GPS module into my Pixhawk 2 then I get the following error in QGC in the calibration compass.

Start the individual calibration steps by clicking one of the buttons to the left.
[cal] calibration started: 2 mag
[cal] Skipped scale calibration, sensor 1
[cal] Skipped scale calibration, sensor 2
[cal] Mag 3 no device id, abort
[cal] calibration failed: mag

If I remove the module, then I can calibrate the compass without issues.

What is the problem here? I thought this module was designed to work with the PH2.

I think it might have to do with the 3 other internal mags. I’ll open an issue on Github.

I’m having a similar issue with my Pixhawk Mini and the GPS it came with. Anyone know how to solve this?

Mine appears to be solved when I downloaded the latest from master, merged, and then recompiled with my code. It at least let me go through the mag calibration without issues. I have yet to try it IRL.

Sorry, im a bit new with all of this, but I’m having a very similar problem. Where did you download the latest from? And was it a different version than a program like qgroundcontrol downloads automatically? And how exactly did you get the better version on your pixhawk?


Having trouble calibrating Pixhawk mini. First calibrated the Pixhawk mini by itself using QGC. Everything looked good and I could see it moving on the QGC screen. Then I added the GPS unit and telemetry Tx/Rx and put the whole system on a breadboard to test everything out as a system. I got error message mag 0 and mag 1 not calibrated. So I then tried a re-calibration of the entire breadboard with every thing attached. The calibration procedure stopped after the first axis rotations with the Pixhawk beeping, then an error log displayed in QGC. It would not let me continue with the rest of the 6 axis calibration.

What’s the problem?