Pixhawk Mini compass calibration fail


I recently started building my first drone but I have encountered problems trying to calibrate the compass in QGroundControl. I’m using the 3DR Pixhawk Mini FC which I bought in a pack which included the 3DR GPS/Compass module (same as on this page : https://docs.px4.io/v1.9.0/en/flight_controller/pixhawk_mini.html).

The firmware loaded on the FC is PX4 Pro 1.10.1 Stable Release. I had no problems calibrating the gyro and the accelerometer.

Here is the issue :
When I plug in the FC attached to the GPS/Compass module and try to start calibrating the compass this is the error message I get : “Transition denied, shutdown to init”. I tried many times, it’s always the same message.

Then I decided to first plug in the FC and only after that adding the GPS/Compass module to it. At the moment I attache the module to the FC, I get this error message : “Dangerously Low Battery, System shutting down, system does not support shutdown”. If I then try to calibrate the compass, it gives the same error message as earlier : “Transition denied, shutdown to init”.

I finally tried the same two operations but with the FC connected to the Power Module which is powered by my Lipo-battery. Same errors. Except that it adds : “Battery at 0 percent”. The battery is in reality fully charged.

I tried to re-upload the firmware. Same errors. I tried it with a Linux and a Windows computer : same errors.

I don’t really know what else I can try and can’t find any support concerning those error messages. I’m thinking of trying with the ArduPilot firmware but wanted to ask some advice to try to fix the issue with PX4 first. Any ideas ?

Thank you in advance

Okay I figured it out.

After trying ArduPilot and having other issues there, I decided to try again with PX4.
I basically just had to calibrate the battery by measuring the voltage coming out of it with an external voltmeter and entering that value after clicking on ‘Calibrate’ (see picture).

QCG then basically detected my battery was full and everything works fine now.