Pixhawk 4 mini and X8R Not working

#1

Hello,
I am using an S BUS connector and it does not register with my Pix hawk 4 mini. I verified that the reciever works with my Pixhawk 4 but not the Pixhawk 4 mini. Both are using PX4 with Q ground control. I tried factory resetting my device but this did not solve the issue.

Does anyone have a solution to this problem or troubleshooting tips?

-Jordan

Error "Detected 0 radio channels. To operate PX4, you need at least 5 channels"
RC radio calibration, Detected 0 radio channels. To operate PX4, you need at least 5 channels
Pixhawk 4 mini Spektrum calibration issue
#2

It looks like another user is having a similar problem http://discuss.px4.io/t/rc-radio-calibration-detected-0-radio-channels-to-operate-px4-you-need-at-least-5-channels/6669/5?u=j_andia

#3
#4

https://docs.px4.io/assets/flight_controller/pixhawk4mini/pixhawk4mini_rc_dsmsbus.png

#5

Hi Jordan,
what did work for me (using a Graupner GR-12L) was to go to the latest Master Px4 version, neither stable nor beta would connect with SBUS. Master did…

br

Gerd

PixHawk 4 Mini PX4IO not found
#6

Hi there,

The title of your post makes me think you are using a

FrSky X8R receiver and later on you talk of Spectrum transmitter. Is your Spectrum actually bound to your X8R?

I didn’t think that was possible, maybe someone can confirm that.

#7

The same here:
New Pixhawk 4 mini unpacked, made connections to GPS puk, SBUS receiver and to the Power management board. It boots up fine. Blue lights on the puk and controller are flashing slowly, green light on controller. I connected to QGroundControl (MAC) to explore some setup features. First thing was follow the recomendation to update to latest firware.
No good.
Neither blue LEDs flashing nor receiver connection available after a succesful update process. Re-booting, Reset or reFlash did not help. Tried the same on a Windows system, to no avail. Flashing the current master PX4 version is the only way to bring up the system again.
BTW The selection of .PX4 images from other directories in QGC is not possible, only directories are selectable, all files are geyed out.

Before flying any installation I shall wait for a solution to install a stable version…

Blue skies, Jo

Plug in your device via USB to start firmware upgrade.
Gerät gefunden: PX4 FMU V5
Verbunden mit Bootloader:
Version: 5
Board ID: 50
Flash Grösse: 2064384
Keine Firmware Datei ausgewählt
Verbesserungen abgebrochen
<<<<<

#8

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

#9

I had a similar issue. Check out this post: PixHawk 4 Mini PX4IO not found

#10

Gerd,
Using the master version px4 allowed radio connectivity. Thank you for this advice.

I am interested in using ArduPilot now. Have you or anyone had any success with ArduPilot on the Pixhawk 4 mini? I tried stable, beta, and latest and I have not had any success.

-Jordan

#11

Yea it seems to be that pixhawk 4 mini is does not suport V1.8.2, however with the Master version the RC can be recognized.

I was also told that by holybro, however I got another issue, when I calibrate the sensors and then I connect the drone with the motors I get the following error:

FCU: Preflight Fail: Compass Sensors inconsistent
FCU: Not arming: Preflight checks failed

Do you have a clue ??

#12

If your GPS has a built-in compass, then try disabling the internal compass in CAL_MAG1_EN

Good luck.