PIxhawk 4 Mini Help

I bought this FC a few weeks ago and despite my best efforts I can’t fly my drone. I uploaded the latest firmware, configured all sensors and radio inputs, but no matter what, I get a “compass inconsistent” error while in QGroundControl which makes it to where I can’t arm my drone and fly it. I have only found one thing online even remotely close to this problem, but it was solved by disabling the internal compass which I can’t seem to do with QGroundControl.

I cannot use Mission Planner because it wont connect to the Pixhawk. If I use Qgroundcontrol I can upload the PX4 firmware ONLY (PX4 flight stack 1.9.2) and no other firmware offered in Qgroundcontrol or Mission Planner. Any other firmware in both Qgroundcontrol or Mission Planner causes the board to error out, light up the B/E error light which is a bootloader issue I gather.

Can anyone shed some light on this? I emailed the company I bought the board from and they told me to use Mission Planner to disable the compass like I already tried, but cannot do for whatever reason.

Do you want to be using px4 or ArduPilot? For ArduPilot/Missionplanner help, discuss.ardupilot.org is better than here.
If you do want to be using ArduPilot, download this firmware: http://firmware.ardupilot.org/Copter/stable/PH4-mini/arducopter.apj
Flash it as a custom firmware in Missionplanner, then press “CTRL-F” and click the update bootloader button.
It will still work with QGC as well as Missionplanner afterwards, but should identify the board as a PH4-mini rather than generic FMUv5.

Ok, went ahead and did that. As soon as I successfully loaded the new firmware onto the FC, the B/E red indicator light starting blinking just like every other time I’ve tried to put new firmware on. Upgrading the bootloader just errors out. The board will connect to QGroundControl and allow me to calibrate everything, but just like every other time, it won’t bind with my transmitter. If I load the firmware version that can’t calibrate the compass, that’s the only time it lets me bind to my transmitter, but it’s useless because as mentioned before, the compass error prevents me from arming the copter.

Can anyone else shed some light on this issue? I’m dead in the water.


I’ve got the same controller and faced some of your issues. I finnaly get everything working since I put this version : https://github.com/PX4/Firmware/releases/download/v1.9.2/px4_fmu-v5_default.px4
It worked as soon as I changed the multicopter version for this default version.

Also, calibrate your compas far away from any metallic or magnetic things (cellphones, etc…) it helped a lot in my case.
Hope I helped.

Hi, I have a radio link mini pix. I want to add flaps, butbI don’t know how to configure pin 5 or 6. Does any know about this? Also, how do I add an additional motor to pin 5 or 6? Everything else works fine.