Pixhawk 4 Mini Failed to Communicate with IO

#1

I am experiencing firmware issues with the Holybro Pixhawk 4 Mini.

The Pixhawk 4 Mini comes pre-installed with PX4 v1.8.0 dev according to the product page:

https://shop.holybro.com/pixhawk4-mini_p1120.html

Out of the box it functions fine, but when I updated the firmware to v1.8.2 stable I get the error “failed to communicate with IO: abort”. As a result, none of the external IO devices work properly and I get the 5 extended beeps from the buzzer that signifies an IO problem. However, when I changed the firmware to the latest developer (master) build, the IO works fine. I also tried building v1.8.0 stable from from github, but I get the same IO error when loading it onto the board.

Does anybody know why the IO on the Pixhawk 4 Mini works on the developer build, but not on the stable builds?

I have conducted testing with the latest developer build through QGC, but it is too unreliable to use. I really need a stable release for my current project.

Any help is much appreciated.

#2

I had the same problem. After firmware update with QGC to the latest stable version there was IO error, no communication with receiver, no blue led. Only update to developer build was possible.

Following the description of px4.io I set up all tools (MAC) and finally with:

bash
ulimit -S -n 2048
git clone https://github.com/PX4/Firmware.git
make px4_fmu-v5_default upload

it came back to the situation before first tried update.
The cloned depository is 1.8.2 but
QGC shows ver. 1.8.0beta !??

Blue skies, Jo

#3

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

#4

Check out this post: PixHawk 4 Mini PX4IO not found I had a similar issue.

#5

I had the same issue using QGroundControl to set up a new Pixhawk 4 mini, e.g, “failure to communicate with IO”. I found it was not an issue with the FC, but with the computer I was using. I switched to another one and all was good.

#6

I contacted Holybro and was told that the Pixhawk 4 Mini does not support 1.8.2. The Pixhawk 4 Mini requires the developer build (master) for functional I/O. 1.9.0 beta is working.