Pixhawk 4 mini Baro Sensor #0 missing ( suddenly at home)

Dear All,
First of all thank you for all the information and support that helped immensely my research.

I bought two months ago a Pixhawk 4 Mini. It worked fantastically until a few days ago without problems nor crashes.

It all happened at home, suddenly apm checks fail due the barometer failure:

Tried all hints I found in this and other websites.

Reviewing parameters (that I did not change earlier) / try changing setting, reset , reload saved configuration, etc.

re-Install latest pix4 with QGroundControl

install plane to erase all and reinstall ardupilot latest (4.07)

re-Install latest pix4 with QGroundControl

power first the quad before connection to QGC or Mission Planner

I noticed that while in ardupilot the S/B led was solid red, it looks ok (no red light on) with pix4 I have a promising PWR as solid green and ACT blinking blue.

It’s hard to believe it is an hardware failure because it was all good when I plugged the usb an hour earlier.
Of course this happened a few week away from my college project presentation.

APM: Preflight Fail: Baro Sensor #0 missing
pixhawk 4 mini APM: Preflight Fail: Baro Sensor #0 missing

Should I give up and consider the Pixhawk 4 mini suddenly damaged ?

Thank you in advance,

I do think it is a hardware fault and that the electronic components fail somehow. I personally think it’s a design error in the Pixhawk 4 Mini and that it should be fixed, since it seems to be a very common error in the forums, always with the mini and always without any crashes.

I think you should try with an external barometer as I explained here: Pixhawk 4 mini baro sensor 0 missing - #13 by Murray_Louw

This will be your cheapest and fastest option. You don’t even have to customise firmware if you are willing to manually start the baro driver through the MAVlink Console on QGC. Or you could buy a new Pixhawk 4 mini, or better yet, a different flight computer.