Pixhawk 4 mini baro sensor 0 missing

I have a pixhawk 4 mini FMUv5 with firmware 1.9.0 stable release and can not arm the copter. Error message is baro sensor 0 missing.
How can I find out if the baro sensor 0 works?

Good day, just check this parameter CAL_BARO_PRIME and calibrate again.

Here are some parameters of the baro sensor

CAL_BARO_PRIME 0 Primary baro ID
SENS_BARO_QNH 1013.250 hPa QNH for barometer
SYS_CAL_BARO 0 Enable auto start of barometer at the next power up
SYS_HAS_BARO Enabled Control if the vehicle has a barometer

If I disable SYS_HAS_BARO I can start the copter. But that can not be the solution.
I have already set the parameter sys_cal_baro to 1 and thus recalibrated. Unfortunately did not bring.

Here is a list of PX4Mini devices


Device “Baro0” is missing in the list.

There is a pressure gauge in the MAVLink Inspector. I do not know if that means the Baro0 sensor or the speed sensor.

Is my PX4Mini broken? According to the description he has a barometer (MS5611)

I am using PX4
I was able to arm the copter until yesterday
today I am getting the warning “Preflight fail : Baro Sensor #0 missing”
I have tried and checked the previous posted and have the same results.
Have you found a solution?

The problem still exists with me.
Do you have a px4 or px4 mini?
Please post your device list (ls / dev)?

I have a px4.
This is ls /dev list

When i tried “ms5611 info”
I get an empty response
After I try “ms5611 start”
I get this
ms5611Start

I have exactly same problem


everything was working before upgrading from 1.9.0 to 1.9.1.
On my side I did not make a change of settings except today I am grounded my drone refuses to arm.
Do you have any idea where this problem might come from and what elements would you need to do an analysis?

I use qgroundcontrol 3.5.3 and a pixhawk 4 (holybro)

thank you