Pixhawk 4 Hardware faulty?

#1

I’v received my Pixhawk 4 today.
I’ll go step by step what I have found happening:

First I plugged in the Pixhawk 4 to my usb port, just to do a quick check, etc. It booted up fine. But I’ve noticed that it intermittently starting to reset after a few seconds.

I plugged in the GPS module so that I can hear the buzzer and see status LED. Boot up fine and the power up tune played. Status LED went soft pulsing blue. Again I noticed the PixHawk reset intermittendly (At this stage I was thinking faulty USB cable).

Then I tried to connect to QGC and had no joy. Tried Mission control and also no joy.

While I’m still checking my port settings, I noticed something else, When it reset itself like that, the main indicator LED on the GPS goes off, the ACT, B/E and PWR led lid constantly on the FMU (actually with a slight flicker). the PWR, B/E lid constantly and the ACT led flicker (like normal) on I/O. Resetting the I/O works but not the FMU.

Then, the above state of LEDs started to stay like that permanently.

Obviously, I tried doing a firmware upgrade, but that does not work because of the no connect.

I tested a Pixhawk 2.4.8 with the same cable and settings, QGC and Mission control and it works perfectly.

Is there a hard reboot method I can do to clear the Flash and bootloader and try over?

Or is it just hardware?

Sorry for the long post. Have to make sure I covered everything before ordering a replacement.

1 Like
#3

Hello! Could be a USB connection issue, without the physical hardware, it’s hard to diagnose at this point. You can contact Holybro’s product service team at productservice@holybro.com to ask for a RMA.

#4

I would suspect that it almost seem like your USB doesn’t have enough voltage/amperage to maintain and sustain the needed power level. Have you tried powering it first via the PCB then connecting via USB?

Good luck.

#5

Thanks for your replies.
It is not an USB power problem.
I have tested an older Pixhawk 2.4.8 with the same USB cable that came with the Pixhawk 4, all good.
I have also tested with an original Raspberry power supply capable of delivering 2.0Amps, which is more than enough.
Next step would be to use the Power PCB with a LiPo, but I know at this stage it would make no difference.

The Pixhawk 4 is not going through its boot up sequence. I think a FMU part failed.

@JingerZ, thanks for the link to contacting Holybro, but I did not buy it from them direct (Banggood, which is an original Holybro supplier). First I want to sort it out with them to get a replacement. If not then I’ll contact Holybro.

#6

I made a video
https://youtu.be/eC6S-HRAJ20

#7

Manufacturer confirmed it is a FC problem. Sending me a replacement. Was not a hassle to get sorted via Banggood, just a delay due to the Chinese October holidays. Closing subject.

1 Like