The FMU no longer works And no LED lights up and the pixhawk heats

I need some help, i was using my Pixhawk1 and when i plug the USB to use it, No Led of the FMU lights up and the Pichawk heats
any solutions ?
This is a picture of my issue

This looks like no genuine 3RD Pixhawk to me. If this is the case there are most probably lower Quality Parts or Other Parts than with the Original. One newer knows what the Chinese are using. Power Supply Problems are common with Chinese Clones.

This is mostly a Software Exchange, so you have to check with your Vendor/Supplier or if you are skilled, try to find and fix the Problem on your own. Schematics of Pixhawk (aka FMUv2) are OpenHardware.

The problem is that I was able to use it for a few days, and on the Mission Planner software, it gave me good results.
Does even the Chinese pieces do the same thing ?

How do you detect the clone from the original one??

try to access the shell of NuttX system using mavlink,

3rd does not longer produce Pixhawk. Most likely all sold Pixhawks now are Chinese Counterfeit. Some may work, some don’t.

Sir same problem I faced today, In testing, pixhawk was on properly continuesly about an hour, and suddenly FMU power and b/e led stopped, and pixhawk disconnected.
Before that problem pixhawk was shown some problem in gyro, ahrs and last time continues problem was “Bad logging”.
Is there any solution to solve FMU problem or can we say that pixhawk is died ? Please guide anyone . . .

Chinese copies use genuine ST chips but then they cut cost on all supporting components like voltage regulators, capacitors, resistors, level shifters etc, sometimes they remove some components, sometimes a voltage regulator they put in does not cope with the load and dies, it can take the FMU or IO down, if you are lucky it will be just a voltage regulator but To replace SMD components you will need a hot air station a magnifying glass or a microscope, parts, knowledge of the circuits, steady hand and loads of patience.
I have one of these with an FMU chip turning into a heater so I replaced it with another chip but now the barometer is not working, I have tried three barometer chips pulled from other dead boards but still no joy.
I think it is a waste of time, you will be better off buying from a known source, there are some good clones on the market, I use one from Drotek and I have never had any problems, check forums people have used clones before and many of them are in the same situation you are.

1 Like

Does anyone here have experience with clones, good or bad?
Would you like to share it?

Sir many thanks for to share your valuable practical experience, can you suggest buying link for good clone.
Sir how we will know good or bad clone, any idea ?

I use this one in my Tarot 650 and I fitted one in a Phantom 2 , the board is well made the FMU is rev 3 so there is no 1MB problem, the main differences are that the connectors are different, just servo connectors on both sides and the case is separate, but I have designed and 3d printed a case with vibration damping for the tarot 650 frame.

You might want to search on rc forums, there is a lot of discussions about pixhawk clones and issues.

Can you opem the pixhawk and check if there are any signs of component damage inside?

I have had one dead pixhawk, when I opened it the voltage regulator was burned, sometimes you can see damage on components, if it is only the voltage regulator then you can try to replace it, I have replaced the FMU chip too, but there is no guarantee that it will work again, as I said before it might be a waste of time.

I have the UnmannedTechShop Hawk, it’s a fantastic clone manufactured to the exact same spec as the original. I spoke to them before I bought it and they confirmed the same bill of materials and board layout is used. I’ve had mine a couple of years and never had an issue.

Good to know, thank you, do they also use the rev3. Chip so there is no 1MB issue?

You would have to ask them if the more recent batches use the rev 3 chip, mine has the rev 1 but its a few years old now. I cannot connect to QGC with USB, which I’m guessing is related to the silicon errata, but its not an issue as I do everything over the telemetry radio. USB firmware update still works ok though.

I have recently replaced an Fmu chip and it is working fine, I have bought the chip in Farnell

so you did replace the main STM32F427?

Yes, I have replaced it and flashed a bootloader with st-link.

ok thx a lot so I will try the same since I have now two orignal Pixhawks with this problem… arg_

i had the problem with the voltage regulator who was burned
So it’s was a wasted time i replaced it but i tought that was another problem with the ARM.
my clone was bought from ebay i think it was good, i made a mistake by inverting the polarization on one of the plugs.
i bought another pixhawk from they have a good product