Pixhawk 2.4.8 malfunction

I bought a diy kit for a hexacopter. After I assembled it and tried to load firmware it seemed to me that I was not paying attention closely to something. From the accelerator and compass calibrating to test flight I was stumped. Once I learned some of those little things ( uncheck the box for reset when plug in and reboot) I finally got a rapidly blinking green led. With the give it a test go I screwed up and put to props in the with the wrong rotation. Needless to say it wasn’t successful. It copter tilted forward and rested on it nose. Not a crash. I righted it and run up the motors the stopped. It was apparent there was something up and went home and discovered my mistake. Replaced the props. Reset the fc and reloaded the firmware and calibrations. As I was doing that I got a “ can’t find board”. I unplugged the fc and tried again. After I “ forced boot loader” and got initial firmware and a message it was”already loaded” then after legacy firmware gave message “board retired loading last available firmware”. All seemed fine down to motor test. Took it back out, got flashing green (fast) had 18 satellites locked but no joy. Back home review what I had and now I can’t see any satellites on transmitter. Replaced gps unit ( I’m a newbie) and still no lock. To top it all off now I don’t get a yellow light let alone RGB. My uneducated feeling is the FC is not working. Can anyone straighten me out?

  • List item

Are you using PX4 or ArduPilot?

What if I said I don’t quite understand all of the different things I got it as a kit I think px4 pixhawk. Since I last posted I tried again to get the lock. After about 30 min it wasn’t locking so I unplugged it replugged it and now no rgb light at all

If you’re using MissionPlanner it’s probably ArduPilot. If QGC you can choose between the two when you flash firmware.