Omnibus F4 with crossfire and mavlink

Hi,

I’m trying to connect my omnibus f4 sd with pixhawk 1.11.2 installed via mavlink over crossfire to my phone. I have connected the crossfire nano rx to USART 1, changing tx and rx as is required for USART.

For some reason, no matter which serial port I select for MAV_0_CONFIG, no mavlink connection is set up. (I’m connecting to the correct port, my crossfire wifi has mavlink over udp enabled and mavlink is set as protocol on my crossfire rx for port 1 and 2). Only when using TELEM 2, I do get a second instance of Mavlink (checked by typing mavlink status in the console when connected to a pc over usb. The mode i get there is called Onboard and as stated before, it doesn’t work.

I’m completely lost here. What can I do to get it to work?

Edit: I just noticed that Onboard is a setting. Changing it to normal doesn’t change that it is not working though

When I plug it in another serial port (the one from the GPS), I am able to set up a connection via mavlink. Is there something in the configuration that is actively blocking using USART1 as a general USART connection? If so, How should I change that so that it does work over USART1?

I’ve got it to work by disabling the rc_input driver and adding TEL1:/dev/ttyS0 to the cmake file. Then configuring MAVLink to go over TEL1 with a baud of 57600 8N1 (Baud settings found under the Serial parameters after setting MAVlink config and rebooting). Since I’m using RC over MAVLink, I have no need for a dedicated rc_input driver. Should I makea pull request with this cmake file so more people can use it this way? I will of course not naming it default but something like rcovermavlink.