Pixhawk - PX4 conection to QGC with TBS Crossfiret

after serveral trials and countless coups of coffee i got the Pixhawk conected to the QGC over the Mavlink and the TBS Crossfire.
If i start the session it takes about 3 minutes for the first initialization. It looks there is a large download from the PX4 to the QGC. After that the speed of the connection is quite fast.
Sometimes it happens that on the Vehicle Setup the Summary is not visible. Could this be a reason from the automatic switch between the Mavlink Version 1 and 2?

Have somebody similar experiance with this type of connetion?

If it would be for interest i would write the complete “How To Do” of the connection procedure.

Best regards,

1 Like

I would be interested in seeing a “How To” I am trying to utilize the pixhawk 2.1 and TBS Crossfire with Diversity Receiver.

Hello Air Supply,

with the latest stable firmware v1.6.5 the problem with the connection issues was gone.
I try to wirte a short “How To Do”.

  • Your crossfire should have at least the firmware 1.36 or above.
  • You have to prepare a cable between the telemetrie 1 and the channel 7 and 8 from the receiver.
  • Take care the TX and RX must be cross over.
  • On the crossfire CH8 is TX and CH7 is RX.
  • I only connect the RX and TX wire to avoid damage regarding different power supplys.
  • Program the receiver output accordingly (output map).
  • Set the MAVLink PPM to ON
  • Activate the MAVLINK Bluettoth connection on your transmitter.

There is a nice video on youtube: https://www.youtube.com/watch?v=fqzAewjQaQU which explain it quite well.

Best regards,

Hello and HELP please!! I have a pixhawk2 cube and TBS diversity rx. I believe I have everything connected right but I am under the impression that I need to do some mavlink configuration within QGC before it will recognize the crossfire. I can not figure out where this may be. When I try to calibrate the RC in QGC I can’t get any signal from the diversity rx. It does have power and it is bound with the crossfire. I have configured the CF according to the above recomendations.
Can someone please point me in the right direction?


Hi Topgun,
It only works with the TBS corssfire TX standard. The micro transmitter is not be able to handle the mavlink.
For the RX both versions are working.
I have connect the RX1 to the RXin on the PIX2 (PPM signal)
The RX7 and RX8 to the serial port 1 (Telemetrie 1)
On the TBS RX you must set the Telemetriy to “ON” an the RC by MAVLink also to “ON”.
If you not set the RC by MAVLink only the MAVLink will work but no RC signals will transmit.
I have test it with the Pixhawk, Pkixhawk 2 and Pixhawk3Pro. All working well.


Thank you! I have gotten the rc working correctly now. I am working on getting flight modes setup currently. The issue I have encountered now is the servos are working but the esc just beeps with no throttle control. Not sure what could be causing this.

Thanks again for your help!

Hi Joshua,

Nice that it has worked with the Crossfire.

The ArduPilot system is installed on my Pixhawk controllers. It is similar to the PX4 so I’m not sure if the following notes synonymous with the PX4 software fit.
The servo output for channel 3 (Throttle) is only active when the system is armed. Otherwise, the channel is switched off or on 1000ms.
The easiest way to control this is to put a servo on the output and see what it does.
If you want to have it exactly you need an oscilloscope to display the output graphically.

Cheers, Markus

Very helpful Markus, thanks for posting this up. I wonder why there aren’t more people using this LRS system with Pix/APM? There’s almost no information online right now. Have you tested connectivity at distance with this setup yet? I’m wondering what the usable range would be. I’m removing an RFD900 from a client’s multirotor and replacing with the Crossfire. Hoping I’ve got decent performance (2km would be nice, 5km would be wonderful!)

from what I understand it is not allowing it to arm because of some “pre-arming” issues. I am not sure where to find these to even adjust them. For example one issue I am getting is preflight fail:mag sensors inconsistant.

Hello Thomas,

I think LRS systems will not prevail in Germany, because we are allowed to fly in the model range only in the direct field of vision.
This can be represented with any 2.4 GHz system.
I chose the Crossfire because I have Blutooth, RC, and Mavlink in one device. Together with a Taranis you have a very sophisticated device for a great price.
I think that 5km for the Crossfire in the full equipment should not be a problem. I flew with 10mW power over 600m and still had an LQ of 100%.
There is a paper on the old PX4 website about TBS Crossifre telemetry via an I2C bus connection. But I never got that to work. Therefore the solution over the serial interface which does its job reliably.


Hello Joshua,

I would recommend working through the manual thoroughly.

As you write, I suspect that the sensors are not calibrated.
You can also switch off parts or all the monitoring for test purposes to be able to arm the system.
All this is very well described in the manual.

I recommend a few quiet days and some pots of coffee. The story is extensive and in no way “plug and play”.

Cheers, Markus

Hello Markus,
When you connect your Crossfire to the Pixhawk, what strength is your telemetry typically? I cannot get any better than 20% on mine. It’s normally around 15%.

I’m using the Pix 2.1 with APM: Copter V3.4.3, Mission Planner 1.3.52.

I’ve connected everything as you’ve written and as shown in the YouTube video. This is really frustrating. Is there a param I need to change in the Pix 2.1 that might affect the signal? Seems like the issue is likely with the Crossfire system or it’s fw? I’ve flashed and tried many different versions of CRSFR fw, all with the same telemetry results (20% is the best I can get).

Also, there’s a noticable delay in control, even though I’ve selected PPM on Ch.1 CRSFR<------>RC IN, so I’m guessing control is being handled by the directly through the telem1 connection with the CRSFR.

Any insight you might offer is greatly appreciated.



Hello Thomas,

it depends on whether you use the Mission Planner (Ardu Pilot) or the QGC (PX4) as Groundstation.
At the QGC, the receiver RSSI and the telemetry level were correct indicated.
With the Mission Planner, I have only around 15% for the telemetry level.
But I do not think this is a level meter more a percentage for the transmission quality. If I use a USB cable for telemetry, I am at 100%.

I do not have a delay in the control because useing a separate cable for the SBUS or PPM (Ch1 Crossfire ==> RC IN).
If you have any delays in the process, check the MicroSD or turn off the log for testing. The amount of data written in the log is enormous.
If saving the data stops, the process is delayed.


HI Markus

Just want to find out if the following setup will work:

TBS crossfire
Pix 2.1 running latest arducopter
Mission planner on Windows laptop
Bluetooth modal plugged into laptop USB to communicate Crossfire?

How else to connect MP to copter mavlink?


Hi Graham,

It should working like You wrote.
On my laptop the Bluetooth was internal. But it should make no difference if the Bluetooth is intern or extern.

Meanwhile I change to the FrSky telemetrie wiht the S.Bus.
There are many converter aviable.
A good one is from Craft&Theorie.
Cheers Markus

I’ve tried to use this with 2 different Pixhawk 1 and different stack versions, e.g. 1.6.5, 1.7.0 and 1.7.3 both stable and dev iterations and couldn’t make it work. To confirm it wasn’t a hardware issue of either the cable or SPORT, I loaded ArduPilot’'s latest version and it recognized it right off the bat. I’ve filed #9737 but not received any response or resolution. Any hints or tips you can provide to make this work would be highly appreciated.


Thought I would jump back in here again. Unfortunately this build has been put away for a while because I couldn’t get it working. I have decided to pull it back out and try again. I have been able to connect CrossFire to the Pixhawk according to Painless360’s instruction. CF set to 8 channels, ch 7&8 are Mavlink RX & TX, bluetooth set to Mavlink. I am connected to the pixhawk though the Telemetry 1 port. All seems to be working well, but the rssi is not regestering unless I assign it to a channel in the CF. When I do that, I lose the function of that channel. (forgot to mention, I’m running ardupilot). I’m also wondering if I should set failsafe to “cut” on the CF. I have several other issues to work through, but
this should get me going on the right track. Thanks for any insight!!

Hello I am new to PX community so be gentle :slight_smile:
My setup: QAV 250 PX4 mini with GPS Motors 2206 / 2300KV Ground Control - QGC
Taranis QX-7 with Crossfire long range module
Rx : TBS crossfire nano
I would like to connect those gaining full potential of crossfire long range
Could you please upload any photo of the project cause I am a little bit confused.

You have 2 options:

  1. Connect your crossfire receiver as a normal RC and connect 2 other pins to one of your fmu’s serial ports for mavlink.
  2. Connect your crossfire receiver only to one of your fmu’s serial ports and enable RC over mavlink in the parameters.

In both cases, you will need to manually enable udp on your transmitter’s wifi module and connect it to an access point. Then also connect QGroundControl to that access point and create an UDP connection where the ip is the ip of your transmitter’s wifi module and the port the port that is configured with the udp settings.


Great thanks for your time.
Since I am total noob I would appreciate if I had a wiring diagram for both options you mentioned or some pictures.
I provide the picture to assist you.

1 Like