Omnibus F4 Pro SD - Ardupilot not working with QGroundControl below v3.5


I am trying to connect an Airbot Omnibus F4 Pro V3 SD to QGroundControl loaded with Ardupilot . However, it fails to connect when using anything below the latest version 3.5. I have managed to get this to work on Mac OS and on my Android phone which have version 3.5, but not on Windows 10 OS because there is no v3.5 available. Will there be a release of version 3.5 on Windows in the near future?

I would prefer to use PX4 for this build instead of Ardupilot, but I cannot get PX4 to install on the Omnibus F4 Pro V3 SD. I have tried following the steps in this link without success:

I have tried flashing the bootloader and PX4 firmware using Betaflight, QGroundControl, and by compiling from source. None of these methods have worked so far. When trying to flash through QGroundControl, the program crashes or I get the following error:

Found device: PX4 FMU V2
Error: Sync: Send Command: Get Command Response: Timeout waiting for bytes to be available
Upgrade cancelled

If anyone is experiencing similar issues and has found a solution, please let me know.

Dupe. Please, post only in one place