Cannot connect to PX4FMU V1 after updating firmware

Hi, today after I installed qgroundcontrol v 3.0 and flashed the firmware with the latest stable version my PX4FMU and IO lost the ability to connect by usb on a mac, the port is no longer available and it doesn’t appear in the macosx console. Also the PX4io is flashing blue every second and in the FMU only the green led is lightning, also the start button is flashing like christmas lightning. I would love any help, specially if is possible to manually flash the firmware *which I suspect is the culprit" with other method (using the SD card or the like).

Thanks, Camilo Blanco

Hey I had the same problem, and managed to fix it. The problem is that Mac computers (starting from OS Mavericks) already have a built-in FTDI driver, and so if you have installed another FTDI driver there will most probably be incompatibility issues between the two drivers.

Check this issue I opened in Github where I explain what my problem was (which it looks that is your same problem) and how I solved it.

Hope it helps!


Hi after analyzing the issue and following the instructions given by Nacho I found the same issue, when I tried to update the PX4 FMU v 1.4.1 using qgroundcontrol v3.0, this update does not solve the problem, when I use the master firmware it sound the familiar tunes, plus another confirmation tone, which I think is from the PX4IO, at the same time the qgroundcontrol program says that I should insert an SD Card into the autopilot. After that I restarted the autopilot it returns to an state where the PX4FMU rapidly flashes red and the PX4IO is in a heartbeat loop *the blue led keeps blinking…then the autopilot doesn’t work.

Thanks for the report. I need to look into this particular board myself again. What you can try in the meantime is to upgrade to 1.4.2 which might be enough to resolve it.

Hi Lorenz, I tried and tried and tried but I haven’t been able to restore the board to its original condition, qgroundcontrol says that the board is not responding and that I should try to close the program and let the board completely reboot. The sd card has no information in it, is completely clean and has no program. when I use the option to flash with the APM firmware it sounds the classic chime, but then the program refuses to connect to the board.

thanks for any lead.

Camilo Blanco