Ugh, omnibusf4 pro problems

#1

Trying and trying to use a ReadyToSky Flip32 OmnibusF4 Pro with an rPi running Ubuntu 18.04/ROS Melodic and it’s just not going well. I first tried ArduPilot and was able to get the bootloader installed in DFU mode via BetaFlight and uploader.py to load the firmware but could not get Q Ground Control to connect reliably to configure it.

So I found PX4 and built the bootloader and loaded with dfu-tool and QGC would not load the firmware so I built the firmware from source and installed using make -j1 omnibus_f4sd_default upload and it seemed to work. I could connect and MavLink worked and QGC seemed pretty responsive and reliable. Then I plugged in the GPS and went into QGC and set the port to AUX 6 and rebooted. Now I can’t get QGC to connect. I can reflash bootloader and upload the firmware but QGC will not connect.

It just dawned on my to pull the uSD card and delete the configuration and see what happens…
UPDDATE: deleted the params file and no change.

Is there a similar size board with the same features and in the $50 or less price range which will work better?

UPDATE: I validated the hardware was still 100% a-ok by using betaflight and installing its firmware. Then went back to PX4 bootloader installed, for PX4 firmware, I switched to the beta branch and rebuilt and uploaded and QGC now talks again to the OmnibusF4. Having problems with the Rover airframe since the firmware thinks it’s flying and won’t let me change anything.