Rover 4.0.0 unable to output to servos

Hey y’all, I’m working on building up a manually controlled lawnmower using skid steer. Here’s what I’ve got:

  • Pixhawk 2.4.8 (Set up with Rover 4.0.0 official)
  • Power distribution board (Capable of up to 30A)
  • PPM Encoder
  • 4 Channel transmitter
  • Lipo battery (tested and working on a drone)
  • An ESC per motor (Each 30A)

Pretty standard stuff. I can test the motors and ESCs by plugging them directly into the receiver and getting the motors to spin, so I know that the motors, ESCs, and power distribution board is/are ok. It also means that my transmitter is ok. I was able to hop into Ardupilot and confirm that the Pixhawk is actually getting inputs from my PPM encoder on the receiver (Receiver calibration works just fine). I’ve got my ESCs plugged into output ports 1 and 3, per the documentation.

However, I have three critical issues. First, I can’t run the ESC calibration. The error message I get is “Set param error. Please ensure your version is AC3.3+” despite being on Rover version 4.0.0 official. I’m also not seeing any servo output at all. I tried installing Copter 4.0.7 and was able to test the servo output and see my throttle inputs actually doing something on that Copter version, but the outputs don’t change on Rover. I have channels 1 and 3 configured to be ThrottleLeft and ThrottleRight, and just for giggles I swapped it to just Throttle, but that didn’t change anything. Finally, my motors don’t pulse unless I actually unplug my ESCs from the Pixhawk. Just to see if it would do anything, I’ve even tried disabling arming requirements. Any input I could get from you would be greatly appreciated!

For help with ArduPilot, please ask at