No CPU load information QGControl

Hello. Im just starting with PX4 and during first arming procedure i run into a problem.
Trying arming a drone. Via telemetry i get this error every time “Critical: Fail: No CPU load information”. Maybe someone know where shearch cause of this problem, or is able to direct me where to look for a solution?
Zrzut ekranu 2021-08-25 161328

Hi @MSStukan, the CPU load is probably a module not running and/or present, you can check in your mavlink console and type top once to check cpu load (you can check the system modules here Commands · PX4 Developer Guide), most of the time it should be running upon powering up the FC, could you let us know

  1. What board you use?
  2. What firmware you are using?

I encountered the same problem when using a banggood pixhack 2.4.8 and running the v1.12.1 latest release. Downgrade to v1.11.1 solved the problem

Problem solved. I my case problem was in " version of bootloader in version firmware". What i mean …


In first circle we have main version in second circle we have bootloader version.
If we have newer version of pixhawk1 (2MB Flash) version v2 may not working but not always. In my case worked reload bootloader ->change variable SYS_BL_UPDATE to 1 and load again firmware which led to load v3 bootloader version.
Loading Firmware | PX4 User Guide :wink:

1 Like