Close thanks all

#1

after doing everything but i still can’t arm the copter, report the error: not arming: freflight check fais: position unknow

1 Like
#2

Good day,
what kind of fc and gps module do you have installed?
You must select the correct mag… you must check also if it’s internal or external

#3

hello
I solved the problem but now I have a bigger problem with yaw, when the copter takes off, yaw is out of control, the copter is rotated and I have to land.

#4

Do you have done all the calibrations?
i need to check your log file and the way you installed your fc… just send me a picture pls

#5

Many thanks for your support.
The biggest reason why I could not yaw that my two motor shaft was misaligned,
After receiving the advice I had calibrated it and now it flew successfully.
But the actual parameters of PIDs are still unstable, the aircraft still vibrates when moving,
PX4 is different from ardupilot it does not have autoturn
So how do my planes work more stably, thank you very much

#6

send me pls a picture about how do you have installed your fc… maybe you need dump a little beat

1 Like
#7

my log here: https://logs.px4.io/plot_app?log=cfb710cd-845e-40fb-b82f-08327e0051ae
It seems that copter response is too high when I fly in posthold mode. When I roll and return the copter there is too much shaking and instability.
It seems I have a big problem with RTL mode. although I set RTL but when tx is turned off, RTL does not work and the screen only displays land now. when I flew, I tried to push through RTL mode but the copter actively switched to altitute

#8

I will check your log.
Can you send me how you have installed your fc… and telemetry module

#9

I use telemetry RFD900+, pixhawk 2.1 cube, futaba14sg tx

#10

i saw in your logs high magnetic interference on gps and also high vibration on your fc… just put a foam on the base of your fc… but as long as i cannot see how you installed it i don’t know how advice you

#11

#12

Just put under the base of your fc a little beat of foam for dump so you the fc.
When you engage RTL… hows the behavior of your drone?

#13

after calibration coter has RTL. But the problem here is that the posthold copter holds pretty hard, when I roll and returns a phenomenon that is swaying back and forth and I don’t know how to fix it.