Mocap System Reject Position Control ERROR Message and disarm


I have been getting a reject position control error for the past week. I created a motion capture system in matlab that is publishing to ros and sending data via Mavros to a Pixhawk 4

I am using:
PX4 1.10.0beta
Mavros 0.33.0
Mavlink Master

I’ve tried publishing to odometry/out and vision_pose/pose with messages from Matlab (specific to each topic). When I published to vision_pose/pose, I did see the mavlink inspector “Local_Position_NED” output the correct results (or close to them). Still get the reject position control error. Here are my parameters, mavros terminal output, echo of odometry/out terminal output:

output.pptx (49.2 KB)

Here is my log:

I don’t have any props on my motors and one of my motors is disconnected, but I believe that shouldn’t be the issue. Not sure what else to try, do you know of a next step?

For the tf transforms, I have some confusion, here is my frames.pdf output, it shows 3 children that I don’t know why they appear (“map_ned”, “odom_ned”, “base_link_frd”). Shouldn’t these not exist and it should just be map-> odom->base_link?
frames (1).pdf (18.9 KB)

I do receive data in mavlink, however, the odometry and IMU quaternions are different (i am publishing (0, 0, 0, 1) to odometry topic, so I dont know why it says 0.7071, 0, 0, 0.7071:

Also, I still get the “[ INFO] [1574963525.804813497]: HP: requesting home position” warning and reject position control