Mission transfer failed


Almost every time that I try to use QGroundControl to plan a mission, the same error message is displayed on my computer. It says that it was not able to transfer the mission into the drone and that I should try again. As the message is not really clear and does not tell me where the error comes from, I came to this forum in order to find help.

I am using QGC Version: 3.3.0 with a Pixhawk px4 Firmware.

Hey @Pauloledes,

Can you provide few more details?

  • Which PX4 firmware version are you using?
  • Which vehicle are you using, and which Pixhawk?
  • Which connection is used (e.g. 3DR Telemetry)?

Hi @Marili, thanks for your quick answer.

I think I am using the latest version of PX4 Firmware and Pixhawk 4. (Not sure about that though as I can not read it somewhere properly, even after following the instructions given here https://github.com/PX4/Firmware/issues/5854)
I had these problems using the simulation software jMAVSim, on QGC I had selected the Quadrotor X, DJI Flame Wheel F330.

Hi @Pauloledes,
I am not sure I completely understand, are you trying to do HITL or SITL?
Which instructions are you following exactly?

The version can be checked with ver all on the console.

Hi @Marili
Here is a picture where you can see that my Firmware is version
I am trying to do SITL, my goal is to determine which controller is the better between pid, h∞, etc…

I add to this topic more informations so maybe somebody who have had the same problem could help me. I can show you some examples of what works and what does not.

For example, when I simply try to upload a basic mission on the drone simulated by jMAVSim, here is what happens :

As you can see I am not asking something particularly difficult. The waypoints 1,2 and 3 have an altitude of 16 meters (relative to home) and the Planned home position is 13 meters up. When I try to upload, the error message I was talking about earlier in this topic is displayed, it appears here as QGC is connected to jMAVSim but the result is the same if I am connected to my Intel AERO Ready To Fly Drone.

Here is another example that works this time :

So the mission is all the same except that now the waypoint altitude is 1 meter for 1,2 and 3 and the Planned home position is set at 0 meter. This time, the message says that the take off attitude is too low. In my opinion, it is weird that this message is displayed because my drone is here supposed to fly 1 meter up from the ground…
When I try to upload the mission again selecting 10 meters instead of 1, it finally works ! Well, it does work but I have to try to upload it several times since the error message

is still displayed but ends up disappearing if I insist a bit.

Last example :
If I choose to implement a mission where I never ask the drone to take off, it does upload really well without any problem !

I have tried this one with my Intel drone and it does work, except that the drone only arms and does not take off, as expected. As you can guess, it is not really interesting since the main point of a drone is to fly…

So the problem seems to be linked with the altitude but I am not 100 per cent sure. I have tried to uninstall and reinstall QGroundControl but it did not solve the problem. Hopefully somebody can help me now that I have given more info.

Thank you already for your help.


PS : One last thing, sometimes it appears that, if insist a lot, the mission does upload but most of the time, these messages are displayed :

Hi Paul,

it seems that you have an old version installed. I think you should update to the latest version.

Hi @Marili
I have uploaded QGroundControl v3.3.2 and it did not resolve all the problems. It seems that it is easier to upload missions now though.