GPS jumping and not accurate in mission plan mode

Hi to every one

I have a question about the GPS/Compass (3DR). In general, when I open QGroundcontrol station and I go to mission plan, I can see that the GPS position is not accurate, it is jumping even several meters from the position of the Drone.

I am using Jetson TX2 and the GPS is quite close to it. I read that the USB3 port of the Jetson can cause disturbances in the GPS. Could be this the problem?

More technically.

I have QGC-Station and fly-mission-plan, when i set up all the points and I load the mission, I get the error ‘Unable to start mission (‘vehicle not ready’)’.

In other words,

I have tried position control and the drone responded quite satisfactorily using the RC transmitter. However, when I want to try fly mission mode, I can see that the GPS position is jumping even though the QGC takes up till 9 satellites, and the GPS is locked and the HDOP < 1.5 and the VDOP < 1.5.

I can chose the way points and load the program but when I want to change to mission and arm I get the error: I get the error ‘Unable to start mission (‘vehicle not ready’)’.

Do you have a clue about this :slight_smile:

Thank you and looking forward to your replay

Hey @acpl00 are you flying with PX4? do you have access to your logs?


Well I set the position flight mode over QgroundControl station, and the drone was flown with the RC-transmitter.

I do not know where those log files are located :slight_smile:

First you have to determine which Autopilot are you running inside your flight controller, if you happen to be using PX4 then you can follow this guide

Yea I think it is px4, I will read that link, and what shall expect to see concerning the GPS and the error I get?

Once you publish your logs follow the GPS Uncertainty and GPS Noise & Jamming sections.

I would also recommend posting a link here if you need assistance interpreting your logs.

Hi rroche

First at all, thank you for your kindly help :slight_smile:

Well, I read that USB3 is known to be an effective GPS jamming source. So, I have wrapped under the GPS and between the USB3 from Jetson TX2. And, amazingly The GPS status was as follows:

GPS Count 17
GPS lock 3D DGPS lock
HDOP 0.7
VDOP 1.1
Course over ground 219.4

However, when I set up or add way points in mission plan. I could successfully load the mission and when I wanted to start the mission I got the same error:

““Unable to start vehicle not ready”” Even though I tried few times just one log file is available.

I read that the log files only generates when the drone is armed and disarmed, right? well, in that case I armed and disarmed the drone once with the RC-controller.

But, the question is: How can get the log file if it does not allow me to arm and start the mission planer flight mode.

I have the link that has been generated by the flight review.

I share it here:

Also, after I loaded the first mission plan and failed. I set up new mission plan and then when I wanted to load the way points mission, I got the error: ““Mission write failed to send final ack.””

I am looking forward to your replay.